<!DOCTYPE html>
<!--[if IE 8]><html class="ie8"><![endif]-->
<!--[if IE 9]><html class="ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <!--<![endif]-->

<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="user-scalable=yes, width=device-width, initial-scale=1.0, maximum-scale=1, minimum-scale=1">
<meta name="description" content="Utah's news and entertainment magazine for the lesbian, gay, bisexual, transgender and ally community" />

<!--[if lt IE 9]>
	<script src="https://qsaltlake.com/wp-content/themes/voice/js/html5.js"></script>
<![endif]-->

<title>Man charged with murder of Jamaica&#039;s &quot;The Face of Pride,&quot; Dexter Pottinger | QSaltLake Magazine</title>

<!-- This site is optimized with the Yoast SEO plugin v5.3.3 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://qsaltlake.com/news/2017/09/06/unknown-suspect-murder-jamaicas-face-pride-activist-face-charges/" />
<link rel="publisher" href="https://plus.google.com/113070347121609191291/about"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Man charged with murder of Jamaica&#039;s &quot;The Face of Pride,&quot; Dexter Pottinger | QSaltLake Magazine" />
<meta property="og:description" content="The Constant Spring Police have formally charged the man who was implicated in the brutal slaying on Aug. 31 of Dexter Pottinger, a 34-year-old Jamaica LGBT activist, fashion designer. Charged with murder is 21-year-old Romario Brown, a tattoo and make-up artist, and is scheduled to appear in the St. Andrew Parish Court later this month. The &hellip;" />
<meta property="og:url" content="https://qsaltlake.com/news/2017/09/06/unknown-suspect-murder-jamaicas-face-pride-activist-face-charges/" />
<meta property="og:site_name" content="QSaltLake Magazine" />
<meta property="article:publisher" content="https://facebook.com/qsaltlake" />
<meta property="article:section" content="World" />
<meta property="article:published_time" content="2017-09-06T11:33:22+00:00" />
<meta property="fb:admins" content="528783703" />
<meta property="og:image" content="https://qsaltlake.com/wp-content/uploads/2017/09/dexter_pottinger_facebook-e1504717656606.jpg" />
<meta property="og:image:secure_url" content="https://qsaltlake.com/wp-content/uploads/2017/09/dexter_pottinger_facebook-e1504717656606.jpg" />
<meta property="og:image:width" content="888" />
<meta property="og:image:height" content="527" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/qsaltlake.com\/","name":"QSaltLake Magazine","potentialAction":{"@type":"SearchAction","target":"https:\/\/qsaltlake.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/qsaltlake.com\/news\/2017\/09\/06\/unknown-suspect-murder-jamaicas-face-pride-activist-face-charges\/","sameAs":["https:\/\/facebook.com\/qsaltlake","https:\/\/instagram.com\/qsaltlake","https:\/\/www.linkedin.com\/company\/qsaltlake","https:\/\/plus.google.com\/113070347121609191291\/about","https:\/\/www.youtube.com\/user\/QSaltLake","https:\/\/www.pinterest.com\/qsaltlake\/","https:\/\/twitter.com\/qsaltlake"],"@id":"#organization","name":"QSaltLake Magazine","logo":"https:\/\/qsaltlake.com\/wp-content\/uploads\/2015\/08\/qsaltlakeMagazine_logo_red_black_175x73.gif"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="QSaltLake Magazine &raquo; Feed" href="https://qsaltlake.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="QSaltLake Magazine &raquo; Comments Feed" href="https://qsaltlake.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="QSaltLake Magazine &raquo; Man charged with murder of Jamaica&#8217;s &#8220;The Face of Pride,&#8221; Dexter Pottinger Comments Feed" href="https://qsaltlake.com/news/2017/09/06/unknown-suspect-murder-jamaicas-face-pride-activist-face-charges/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/qsaltlake.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=f2f7d84449e45f8087f27b4cb05bc2e7"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='mailpoet_public-css'  href='https://qsaltlake.com/wp-content/plugins/mailpoet/assets/css/public.cae357df.css?ver=f2f7d84449e45f8087f27b4cb05bc2e7' type='text/css' media='all' />
<link rel='stylesheet' id='validate-engine-css-css'  href='https://qsaltlake.com/wp-content/plugins/wysija-newsletters/css/validationEngine.jquery.css?ver=2.7.11.3' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://qsaltlake.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='mks_shortcodes_simple_line_icons-css'  href='https://qsaltlake.com/wp-content/plugins/meks-flexible-shortcodes/css/simple-line/simple-line-icons.css?ver=1.3' type='text/css' media='screen' />
<link rel='stylesheet' id='mks_shortcodes_css-css'  href='https://qsaltlake.com/wp-content/plugins/meks-flexible-shortcodes/css/style.css?ver=1.3' type='text/css' media='screen' />
<link rel='stylesheet' id='vce_font_0-css'  href='https://fonts.googleapis.com/css?family=Work+Sans%3A400%2C800%2C600&#038;subset=latin%2Clatin-ext&#038;ver=2.5' type='text/css' media='screen' />
<link rel='stylesheet' id='vce_style-css'  href='https://qsaltlake.com/wp-content/themes/voice/css/min.css?ver=2.5' type='text/css' media='screen, print' />
<style id='vce_style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='vce_child_load_scripts-css'  href='https://qsaltlake.com/wp-content/themes/voice-child/style.css?ver=2.5' type='text/css' media='screen' />
<link rel='stylesheet' id='meks-ads-widget-css'  href='https://qsaltlake.com/wp-content/plugins/meks-easy-ads-widget/css/style.css?ver=2.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='meks-flickr-widget-css'  href='https://qsaltlake.com/wp-content/plugins/meks-simple-flickr-widget/css/style.css?ver=1.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='meks-author-widget-css'  href='https://qsaltlake.com/wp-content/plugins/meks-smart-author-widget/css/style.css?ver=1.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='meks-social-widget-css'  href='https://qsaltlake.com/wp-content/plugins/meks-smart-social-widget/css/style.css?ver=1.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='meks-themeforest-widget-css'  href='https://qsaltlake.com/wp-content/plugins/meks-themeforest-smart-widget/css/style.css?ver=1.2' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-frontend-style-css'  href='https://qsaltlake.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css?ver=3.7.7' type='text/css' media='all' />
<!--[if lte IE 6]>
<link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='https://qsaltlake.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css?ver=3.7.7' type='text/css' media='all' />
<![endif]-->
<!--[if lte IE 7]>
<link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='https://qsaltlake.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css?ver=3.7.7' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://qsaltlake.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://qsaltlake.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://qsaltlake.com/wp-content/plugins/meks-flexible-shortcodes/js/main.js?ver=1.3'></script>
<script type="text/javascript">
	!function(){var analytics=window.analytics=window.analytics||[];if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.0";
		window.analytics.load("7dsXK8yjQEOYBJ9b7aXgPcJ1v3NeLcsF");
	window.analytics.page();
	  }}();
</script>
<link rel='https://api.w.org/' href='https://qsaltlake.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://qsaltlake.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://qsaltlake.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://qsaltlake.com/?p=42333' />
<link rel="alternate" type="application/json+oembed" href="https://qsaltlake.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2017%2F09%2F06%2Funknown-suspect-murder-jamaicas-face-pride-activist-face-charges%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://qsaltlake.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2017%2F09%2F06%2Funknown-suspect-murder-jamaicas-face-pride-activist-face-charges%2F&#038;format=xml" />
		<script type="text/javascript">
            var _statcounter = _statcounter || [];
            _statcounter.push({"tags": {"author": "Tony Hobday"}});
        </script>
	       <!-- Start of StatCounter Code -->
    <script>
    <!-- 
        var sc_project=6082424; 
        var sc_security="0d5c72ba"; 
      var sc_invisible=1;
        var scJsHost = (("https:" == document.location.protocol) ?
        "https://secure." : "http://www.");
    //-->
document.write("<sc"+"ript src='" +scJsHost +"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="web analytics" href="https://statcounter.com/"><img class="statcounter" src="https://c.statcounter.com/6082424/0/0d5c72ba/1/" alt="web analytics" /></a></div></noscript>   
    <!-- End of StatCounter Code -->
<script data-cfasync="false" src="//load.sumome.com/" data-sumo-platform="wordpress" data-sumo-site-id="96178a0064b7670090e48d0056d1bf00a77d00004cea7500a2ac9400d4c7cd00" async></script><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//qsaltlake.com/?wordfence_logHuman=1&hid=7956D40B9BE2B720C935F6B82C994FC0');
</script>		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<link rel="amphtml" href="https://qsaltlake.com/news/2017/09/06/unknown-suspect-murder-jamaicas-face-pride-activist-face-charges/amp/" /><link rel="icon" href="https://qsaltlake.com/wp-content/uploads/2017/08/cropped-Q_bug-32x32.png" sizes="32x32" />
<link rel="icon" href="https://qsaltlake.com/wp-content/uploads/2017/08/cropped-Q_bug-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://qsaltlake.com/wp-content/uploads/2017/08/cropped-Q_bug-180x180.png" />
<meta name="msapplication-TileImage" content="https://qsaltlake.com/wp-content/uploads/2017/08/cropped-Q_bug-270x270.png" />
<link rel="shortcut icon" href="https://qsaltlake.com/wp-content/uploads/2017/08/cropped-Q_bug.png" type="image/x-icon" />
<!-- ========= WordPress Store Locator (v3.98.2) | http://www.viadat.com/store-locator/ ========== -->
<!-- No store locator on this page, so no unnecessary scripts for better site performance. -->
<!-- ========= End WordPress Store Locator (13252,) ========== -->

</head>

<body class="post-template-default single single-post postid-42333 single-format-standard unknown vce-sid-right">

<div id="vce-main">

<header id="header" class="main-header">
	<div class="top-header">
	<div class="container">

					<div class="vce-wrap-left">
					<ul id="vce_top_navigation_menu" class="top-nav-menu"><li id="menu-item-30137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30137"><a href="https://qsaltlake.com/subscribe-2/">Subscribe</a></li>
<li id="menu-item-30138" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30138"><a title="Gay Salt Lake Business Directory" href="https://qsaltlake.com/business-directory/">QPages</a></li>
<li id="menu-item-30139" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30139"><a href="https://qsaltlake.com/classifieds/browse-classifieds/">Classifieds</a></li>
</ul>			</div>
				
					<div class="vce-wrap-right">
					<div class="menu-social-media-menu-container"><ul id="vce_social_menu" class="soc-nav-menu"><li id="menu-item-41777" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41777"><a href="https://facebook.com/qsaltlake/"><span class="vce-social-name">Facebook</span></a></li>
<li id="menu-item-41778" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41778"><a href="https://twitter.com/QSaltLake"><span class="vce-social-name">Twitter</span></a></li>
<li id="menu-item-41779" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41779"><a href="https://www.instagram.com/qsaltlake/"><span class="vce-social-name">Instagram</span></a></li>
<li id="menu-item-41780" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41780"><a href="https://www.linkedin.com/company/qsaltlake"><span class="vce-social-name">LinkedIn</span></a></li>
<li id="menu-item-41781" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41781"><a href="https://plus.google.com/113070347121609191291"><span class="vce-social-name">Google+</span></a></li>
<li id="menu-item-41782" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41782"><a href="https://www.youtube.com/user/QSaltLake"><span class="vce-social-name">YouTube</span></a></li>
<li id="menu-item-41783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41783"><a href="https://www.pinterest.com/qsaltlake/"><span class="vce-social-name">Pinterest</span></a></li>
</ul></div>			</div>
		
		


	</div>
</div><div class="container header-2-wrapper header-main-area">	
	<div class="vce-res-nav">
	<a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a>
</div>
<div class="site-branding">
		
	
	<span class="site-title">
		<a href="https://qsaltlake.com/" title="QSaltLake Magazine" class="has-logo"><img src="https://qsaltlake.com/wp-content/uploads/2017/08/QSaltLakeMasthead.png" alt="QSaltLake Magazine" /></a>
	</span>

<span class="site-description">Utah LGBT news, bars, views, arts</span>	
	

</div>
	<div class="vce-header-ads">
		<a href="http://tickets.pioneertheatre.org" target="_blank"><img width="728" height="90" src='https://qsaltlake.com/wp-content/uploads/2017/08/PioneerTheatre_728.jpg' alt='' title='PioneerTheatre_728' /></a>	</div>
</div>

<div class="header-bottom-wrapper header-left-nav">
	<div class="container">
		<nav id="site-navigation" class="main-navigation" role="navigation">
	<ul id="vce_main_navigation_menu" class="nav-menu"><li id="menu-item-41844" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-41844"><a href="https://qsaltlake.com/">Home</a><li id="menu-item-30165" class="red menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-30165 vce-cat-3"><a href="https://qsaltlake.com/news/category/news/">News</a>
<ul  class="sub-menu">
	<li id="menu-item-30170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30170 vce-cat-4"><a href="https://qsaltlake.com/news/category/news/local/">Local</a>	<li id="menu-item-30171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30171 vce-cat-5"><a href="https://qsaltlake.com/news/category/news/national/">National</a>	<li id="menu-item-30172" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-30172 vce-cat-41"><a href="https://qsaltlake.com/news/category/news/world/">World</a></ul>
<li id="menu-item-30164" class="orange menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30164 vce-cat-20"><a href="https://qsaltlake.com/news/category/features/">Features</a>
<ul  class="sub-menu">
	<li id="menu-item-30202" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30202 vce-cat-119"><a href="https://qsaltlake.com/news/category/features/feature-stories/">Feature Stories</a>	<li id="menu-item-30201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30201 vce-cat-53"><a href="https://qsaltlake.com/news/category/features/fabulous-people/">Fabulous People</a>	<li id="menu-item-30200" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30200 vce-cat-137"><a href="https://qsaltlake.com/news/category/nightlife/fashion/">Fashion</a>	<li id="menu-item-30203" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30203 vce-cat-138"><a href="https://qsaltlake.com/news/category/features/history/">LGBT History Month</a>	<li id="menu-item-30206" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30206 vce-cat-127"><a href="https://qsaltlake.com/news/category/features/travel/">Travel</a></ul>
<li id="menu-item-30166" class="yellow menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30166 vce-cat-21"><a href="https://qsaltlake.com/news/category/artsandentertainment/">Arts+Entertainmment</a>
<ul  class="sub-menu">
	<li id="menu-item-30173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30173 vce-cat-23"><a href="https://qsaltlake.com/news/category/artsandentertainment/artsnews/">Arts News</a>	<li id="menu-item-30174" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30174 vce-cat-197"><a href="https://qsaltlake.com/news/category/artsandentertainment/comics/">Comics</a>	<li id="menu-item-30176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30176 vce-cat-22"><a href="https://qsaltlake.com/news/category/artsandentertainment/gayagenda/">Gay Agenda</a>	<li id="menu-item-30175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30175 vce-cat-28"><a href="https://qsaltlake.com/news/category/artsandentertainment/diningguide/">Dining Guide</a>	<li id="menu-item-30177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30177 vce-cat-198"><a href="https://qsaltlake.com/news/category/artsandentertainment/hear-me-out/">Hear Me Out</a>	<li id="menu-item-30178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30178 vce-cat-213"><a href="https://qsaltlake.com/news/category/artsandentertainment/interviews/">Interviews</a>	<li id="menu-item-30179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30179 vce-cat-27"><a href="https://qsaltlake.com/news/category/artsandentertainment/restaurant/">Restaurant Reviews</a>	<li id="menu-item-30180" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30180 vce-cat-38"><a href="https://qsaltlake.com/news/category/artsandentertainment/reviews/">Reviews</a>	<li id="menu-item-34619" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34619 vce-cat-122"><a href="https://qsaltlake.com/news/category/artsandentertainment/sundance-festival/">Sundance Film Festival</a></ul>
<li id="menu-item-30167" class="green menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30167 vce-cat-7"><a href="https://qsaltlake.com/news/category/views/">Views</a>
<ul  class="sub-menu">
	<li id="menu-item-30187" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30187 vce-cat-139"><a href="https://qsaltlake.com/news/category/views/mr_manners/">Ask Mr. Manners</a>	<li id="menu-item-30182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30182 vce-cat-124"><a href="https://qsaltlake.com/news/category/views/columnists/creep/">Creep of the Week</a>	<li id="menu-item-30188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30188 vce-cat-37"><a href="https://qsaltlake.com/news/category/views/editorial-cartoon/">Editorial Cartoon</a>	<li id="menu-item-30189" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30189 vce-cat-36"><a href="https://qsaltlake.com/news/category/views/guest-editorials/">Guest Editorials</a>	<li id="menu-item-30183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30183 vce-cat-15"><a href="https://qsaltlake.com/news/category/views/columnists/lambdalore/">Lambda Lore</a>	<li id="menu-item-30190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30190 vce-cat-8"><a href="https://qsaltlake.com/news/category/views/letters/">Letters</a>	<li id="menu-item-30184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30184 vce-cat-10"><a href="https://qsaltlake.com/news/category/views/columnists/michaelaaron/">Michael Aaron</a>	<li id="menu-item-30185" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30185 vce-cat-18"><a href="https://qsaltlake.com/news/category/views/columnists/health/">Q Health</a>	<li id="menu-item-30186" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30186 vce-cat-135"><a href="https://qsaltlake.com/news/category/views/columnists/queershift/">Queer Shift</a>	<li id="menu-item-41449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41449 vce-cat-50"><a href="https://qsaltlake.com/news/category/views/columnists/the-perils-of-petunia-pap-smear/">The Perils of Petunia Pap Smear</a>	<li id="menu-item-30194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30194 vce-cat-13"><a href="https://qsaltlake.com/news/category/views/columnists/whosyourdaddy/">Who&#8217;s Your Daddy</a></ul>
<li id="menu-item-30168" class="blue menu-item menu-item-type-taxonomy menu-item-object-post_format menu-item-30168"><a href="https://qsaltlake.com/news/type/video/">Video</a><li id="menu-item-35667" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35667"><a href="https://qsaltlake.com/current-q/">Online Edition</a><li class="search-header-wrap"><a class="search_header" href="javascript:void(0)"><i class="fa fa-search"></i></a><ul class="search-header-form-ul"><li><form class="search-header-form" action="https://qsaltlake.com/" method="get">
						<input name="s" class="search-input" size="20" type="text" value="Type here to search..." onfocus="(this.value == 'Type here to search...') && (this.value = '')" onblur="(this.value == '') && (this.value = 'Type here to search...')" placeholder="Type here to search..." /></form></li></ul></li></ul></nav>	</div>
</div></header>

<div id="main-wrapper">



	

<div id="content" class="container site-content vce-sid-right">
	
			
	<div id="primary" class="vce-main-content">

		<main id="main" class="main-box main-box-single">

		
			<article id="post-42333" class="vce-single post-42333 post type-post status-publish format-standard has-post-thumbnail hentry category-world">

			<header class="entry-header">
							<span class="meta-category"><a href="https://qsaltlake.com/news/category/news/world/" class="category-41">World</a></span>
			
			<h1 class="entry-title">Man charged with murder of Jamaica&#8217;s &#8220;The Face of Pride,&#8221; Dexter Pottinger</h1>
			<div class="entry-meta"><div class="meta-item date"><span class="updated">16 hours ago</span></div><div class="meta-item comments"><a href="https://qsaltlake.com/news/2017/09/06/unknown-suspect-murder-jamaicas-face-pride-activist-face-charges/#respond">Add Comment</a></div><div class="meta-item author"><span class="vcard author"><span class="fn">by <a href="https://qsaltlake.com/news/author/tony-hobday/">Tony Hobday</a></span></span></div><div class="meta-item views">73 Views</div></div>
		</header>
	
	
	
					
			 	
			 	<div class="meta-image">
					<img width="810" height="481" src="https://qsaltlake.com/wp-content/uploads/2017/09/dexter_pottinger_facebook-e1504717615846-810x481.jpg" class="attachment-vce-lay-a size-vce-lay-a wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2017/09/dexter_pottinger_facebook-e1504717615846-810x481.jpg 810w, https://qsaltlake.com/wp-content/uploads/2017/09/dexter_pottinger_facebook-e1504717615846-300x178.jpg 300w, https://qsaltlake.com/wp-content/uploads/2017/09/dexter_pottinger_facebook-e1504717615846-768x456.jpg 768w, https://qsaltlake.com/wp-content/uploads/2017/09/dexter_pottinger_facebook-e1504717615846-468x278.jpg 468w, https://qsaltlake.com/wp-content/uploads/2017/09/dexter_pottinger_facebook-e1504717615846-600x356.jpg 600w, https://qsaltlake.com/wp-content/uploads/2017/09/dexter_pottinger_facebook-e1504717615846-1140x677.jpg 1140w, https://qsaltlake.com/wp-content/uploads/2017/09/dexter_pottinger_facebook-e1504717615846-1320x783.jpg 1320w" sizes="(max-width: 810px) 100vw, 810px" />
									</div>

									<div class="meta-author">
					
						
							<div class="meta-author-img">
								<img src="https://qsaltlake.com/wp-content/uploads/2010/06/hobdaySexy2-222x180.jpg" width="100" height="81" alt="Tony Hobday" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 alignnone photo" />							</div>
							<div class="meta-author-wrapped">Written by <span class="vcard author"><span class="fn"><a href="https://qsaltlake.com/news/author/tony-hobday/">Tony Hobday</a></span></span>
							</div>

						
				    </div>
				
					
	    
		
	<div class="entry-content">
		<p>The Constant Spring Police have formally charged the man who was implicated in the brutal slaying on Aug. 31 of Dexter Pottinger, a 34-year-old Jamaica LGBT activist, fashion designer. Charged with murder is 21-year-old Romario Brown, a tattoo and make-up artist, and is scheduled to appear in the St. Andrew Parish Court later this month.</p>
<p>The lack of information released to the public about the Brown and  his motive behind Pottinger’s murder since the arrest had led to speculation on social media, such as Instagram, about whether it’s a disgruntled lover, a woman, or if the suspect is underage. Accusations against a Jamaican comedian called ‘Quite’ Perry (who was reported by a colleague to be the last person seen with Pottinger) were also released to the news outlet Loop Jamaica: <a href="http://www.loopjamaica.com/content/quite-perry-turns-his-lawyer-pottinger-case">www.loopjamaica.com/content/quite-perry-turns-his-lawyer-pottinger-case</a>).</p><div class="qsalt-injection1" style="float: left; " id="qsalt-206507626"><div style="margin-right: 9px; " id="qsalt-429731234"><a href="http://enlightenlaser.com" target="_blank"><img width="350" height="250" src="https://qsaltlake.com/wp-content/uploads/2017/08/EnlightenLaser_banner_Mustache_350x250.jpg" alt="" title="EnlightenLaser_banner_Mustache_350x250" srcset="https://qsaltlake.com/wp-content/uploads/2017/08/EnlightenLaser_banner_Mustache_350x250.jpg 350w, https://qsaltlake.com/wp-content/uploads/2017/08/EnlightenLaser_banner_Mustache_350x250-300x214.jpg 300w" sizes="(max-width: 350px) 100vw, 350px"></a></div></div>
<p>Last week, Pottinger was murdered in his home in Kingston, Jamaica. Neighbors had heard screams for help, screams of “murder!” which ironically fell on deaf ears as the neighbors did nothing — a similar reaction to the 1964 murder of Kitty Genovese, a lesbian, who screamed for help outside her New York City apartment building while most neighbors did nothing.</p>
<p>Maurice Tomlinson, a Jamaican LGBT activist now living in Canada after threats on his own life, wrote on his Facebook page, “To die knowing that your neighbors heard you screaming murder but did nothing.” “The horror.”</p>
<p>Now, some friends of Pottinger, who was dubbed “the face of Pride” in 2016, say that his neighbors did nothing because he was gay. However, reports indicate that Pottinger’s Honda CRV was found miles from his home in Stony Hill, where Brown lives, and that a television and two iPhones were missing from within the house, <span style="font-weight: 400;">meaning either the murder could have been unrelated to his sexuality or the theft was used as a smokescreen.</span></p>
<p><span style="font-weight: 400;">“What is distressing is the speed with which many have rushed to blame his orientation for his murder,” Tomlinson told <em>The Daily Beast</em>. “This underscores the homophobia that still permeates Jamaica.”</span></p>
<p>While strides to inclusiveness have been made, homosexuality is still against the law in Jamaica.</p>
<p> </p>
	</div>

	
			<footer class="entry-footer">
			<div class="meta-tags">
							</div>
		</footer>
	
		  	
	<div class="vce-share-bar">
		<ul class="vce-share-items">
			<li><a class="fa fa-facebook" href="javascript:void(0);" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2017%2F09%2F06%2Funknown-suspect-murder-jamaicas-face-pride-activist-face-charges%2F&amp;t=Man+charged+with+murder+of+Jamaica%26%238217%3Bs+%26%238220%3BThe+Face+of+Pride%2C%26%238221%3B+Dexter+Pottinger"></a></li><li><a class="fa fa-twitter" href="javascript:void(0);" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2017%2F09%2F06%2Funknown-suspect-murder-jamaicas-face-pride-activist-face-charges%2F&amp;text=Man+charged+with+murder+of+Jamaica%26%238217%3Bs+%26%238220%3BThe+Face+of+Pride%2C%26%238221%3B+Dexter+Pottinger"></a></li><li><a class="fa fa-google-plus" href="javascript:void(0);" data-url="https://plus.google.com/share?url=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2017%2F09%2F06%2Funknown-suspect-murder-jamaicas-face-pride-activist-face-charges%2F"></a></li><li><a class="fa fa-pinterest" href="javascript:void(0);" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2017%2F09%2F06%2Funknown-suspect-murder-jamaicas-face-pride-activist-face-charges%2F&amp;media=https%3A%2F%2Fqsaltlake.com%2Fwp-content%2Fuploads%2F2017%2F09%2Fdexter_pottinger_facebook-e1504717656606.jpg&amp;description=Man+charged+with+murder+of+Jamaica%26%238217%3Bs+%26%238220%3BThe+Face+of+Pride%2C%26%238221%3B+Dexter+Pottinger"></a></li><li><a class="fa fa-linkedin" href="javascript:void(0);" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2017%2F09%2F06%2Funknown-suspect-murder-jamaicas-face-pride-activist-face-charges%2F&amp;title=Man+charged+with+murder+of+Jamaica%26%238217%3Bs+%26%238220%3BThe+Face+of+Pride%2C%26%238221%3B+Dexter+Pottinger"></a></li>		</ul>
	</div>
	
	 
</article>
		
					<nav class="prev-next-nav">
			
		<div class="vce-prev-link">
			<a href="https://qsaltlake.com/news/2017/09/06/transgender-womans-murder-featured-investigation-discoverys-grave-mysteries/" rel="next"><span class="img-wrp"><img width="375" height="195" src="https://qsaltlake.com/wp-content/uploads/2017/09/ty-underwood-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="" /><span class="vce-pn-ico"><i class="fa fa fa-chevron-left"></i></span></span><span class="vce-prev-next-link">Transgender woman’s murder featured on Investigation Discovery’s &#8216;Grave Mysteries&#8217;</span></a>		</div>

		
			
		<div class="vce-next-link">
			<a href="https://qsaltlake.com/news/2017/09/06/homosexuality-lds-church/" rel="prev"><span class="img-wrp"><img width="375" height="195" src="https://qsaltlake.com/wp-content/uploads/2017/09/Greg-Prince-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="" /><span class="vce-pn-ico"><i class="fa fa fa-chevron-right"></i></span></span><span class="vce-prev-next-link">Researcher to discuss biology of homosexuality and the LDS Church</span></a>		</div>	
	</nav>		
		</main>

		
					
	
	<div class="main-box vce-related-box">

	<h3 class="main-box-title">You may also like</h3>
	
	<div class="main-box-inside">

					<article class="vce-post vce-lay-d post-42239 post type-post status-publish format-standard has-post-thumbnail hentry category-world">
	
 		 	<div class="meta-image">			
			<a href="https://qsaltlake.com/news/2017/08/30/chile-gay-marriage-bill-table-regional-anti-gay-violence-becoming-extreme/" title="Chile gay marriage bill on the table; regional anti-gay violence becoming more extreme">
				<img width="145" height="100" src="https://qsaltlake.com/wp-content/uploads/2017/08/chilepresident-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2017/08/chilepresident-145x100.jpg 145w, https://qsaltlake.com/wp-content/uploads/2017/08/chilepresident-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" />							</a>
		</div>
		

	<header class="entry-header">
					<span class="meta-category"><a href="https://qsaltlake.com/news/category/news/world/" class="category-41">World</a></span>
				<h2 class="entry-title"><a href="https://qsaltlake.com/news/2017/08/30/chile-gay-marriage-bill-table-regional-anti-gay-violence-becoming-extreme/" title="Chile gay marriage bill on the table; regional anti-gay violence becoming more extreme">Chile gay marriage bill on the table; regional anti...</a></h2>
			</header>

</article>					<article class="vce-post vce-lay-d post-42167 post type-post status-publish format-standard has-post-thumbnail hentry category-world">
	
 		 	<div class="meta-image">			
			<a href="https://qsaltlake.com/news/2017/08/17/organizers-cancel-pride-uganda-2017/" title="Organizers cancel Pride Uganda 2017">
				<img width="145" height="100" src="https://qsaltlake.com/wp-content/uploads/2017/08/UgandaPride-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2017/08/UgandaPride-145x100.jpg 145w, https://qsaltlake.com/wp-content/uploads/2017/08/UgandaPride-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" />							</a>
		</div>
		

	<header class="entry-header">
					<span class="meta-category"><a href="https://qsaltlake.com/news/category/news/world/" class="category-41">World</a></span>
				<h2 class="entry-title"><a href="https://qsaltlake.com/news/2017/08/17/organizers-cancel-pride-uganda-2017/" title="Organizers cancel Pride Uganda 2017">Organizers cancel Pride Uganda 2017</a></h2>
			</header>

</article>					<article class="vce-post vce-lay-d post-41951 post type-post status-publish format-video has-post-thumbnail hentry category-world post_format-post-format-video">
	
 		 	<div class="meta-image">			
			<a href="https://qsaltlake.com/news/2017/08/03/beaten-gay-sparks-online-debate/" title="Video: James and Dain: &#8216;Beaten up for being gay&#8217; sparks online debate">
				<img width="145" height="100" src="https://qsaltlake.com/wp-content/uploads/2017/08/jamesdain-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2017/08/jamesdain-145x100.jpg 145w, https://qsaltlake.com/wp-content/uploads/2017/08/jamesdain-300x208.jpg 300w, https://qsaltlake.com/wp-content/uploads/2017/08/jamesdain-468x324.jpg 468w, https://qsaltlake.com/wp-content/uploads/2017/08/jamesdain-600x415.jpg 600w, https://qsaltlake.com/wp-content/uploads/2017/08/jamesdain-380x260.jpg 380w, https://qsaltlake.com/wp-content/uploads/2017/08/jamesdain-e1501782187929.jpg 500w" sizes="(max-width: 145px) 100vw, 145px" />									<span class="vce-format-icon">
					<i class="fa fa-play"></i>
					</span>
							</a>
		</div>
		

	<header class="entry-header">
					<span class="meta-category"><a href="https://qsaltlake.com/news/category/news/world/" class="category-41">World</a></span>
				<h2 class="entry-title"><a href="https://qsaltlake.com/news/2017/08/03/beaten-gay-sparks-online-debate/" title="Video: James and Dain: &#8216;Beaten up for being gay&#8217; sparks online debate">Video: James and Dain: &#8216;Beaten up for being...</a></h2>
			</header>

</article>					<article class="vce-post vce-lay-d post-40883 post type-post status-publish format-standard hentry category-national category-world">
	
 		 	<div class="meta-image">			
			<a href="https://qsaltlake.com/news/2017/04/18/april-national-news/" title="April World and National News">
				<img width="145" height="100" src="https://qsaltlake.com/wp-content/uploads/2017/08/NoPic-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2017/08/NoPic-145x100.jpg 145w, https://qsaltlake.com/wp-content/uploads/2017/08/NoPic-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" />							</a>
		</div>
		

	<header class="entry-header">
					<span class="meta-category"><a href="https://qsaltlake.com/news/category/news/national/" class="category-5">National</a> <span>&bull;</span> <a href="https://qsaltlake.com/news/category/news/world/" class="category-41">World</a></span>
				<h2 class="entry-title"><a href="https://qsaltlake.com/news/2017/04/18/april-national-news/" title="April World and National News">April World and National News</a></h2>
			</header>

</article>					<article class="vce-post vce-lay-d post-39891 post type-post status-publish format-standard has-post-thumbnail hentry category-local category-world">
	
 		 	<div class="meta-image">			
			<a href="https://qsaltlake.com/news/2016/10/05/former-utahn-leads-ugandan-swim-team-international-victory/" title="Former Utahn leads Ugandan swim team to international victory">
				<img width="145" height="73" src="https://qsaltlake.com/wp-content/uploads/2016/10/UgandadSwim.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2016/10/UgandadSwim.jpg 653w, https://qsaltlake.com/wp-content/uploads/2016/10/UgandadSwim-300x152.jpg 300w, https://qsaltlake.com/wp-content/uploads/2016/10/UgandadSwim-468x237.jpg 468w, https://qsaltlake.com/wp-content/uploads/2016/10/UgandadSwim-600x304.jpg 600w" sizes="(max-width: 145px) 100vw, 145px" />							</a>
		</div>
		

	<header class="entry-header">
					<span class="meta-category"><a href="https://qsaltlake.com/news/category/news/local/" class="category-4">Local</a> <span>&bull;</span> <a href="https://qsaltlake.com/news/category/news/world/" class="category-41">World</a></span>
				<h2 class="entry-title"><a href="https://qsaltlake.com/news/2016/10/05/former-utahn-leads-ugandan-swim-team-international-victory/" title="Former Utahn leads Ugandan swim team to international victory">Former Utahn leads Ugandan swim team to international...</a></h2>
			</header>

</article>					<article class="vce-post vce-lay-d post-34220 post type-post status-publish format-standard hentry category-world">
	
 		 	<div class="meta-image">			
			<a href="https://qsaltlake.com/news/2014/10/13/catholic-bishops-change-gay-lesbian/" title="Catholic bishops offer &#8220;stunning&#8221; change in beliefs on gays, lesbians">
				<img width="145" height="100" src="https://qsaltlake.com/wp-content/uploads/2017/08/NoPic-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2017/08/NoPic-145x100.jpg 145w, https://qsaltlake.com/wp-content/uploads/2017/08/NoPic-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" />							</a>
		</div>
		

	<header class="entry-header">
					<span class="meta-category"><a href="https://qsaltlake.com/news/category/news/world/" class="category-41">World</a></span>
				<h2 class="entry-title"><a href="https://qsaltlake.com/news/2014/10/13/catholic-bishops-change-gay-lesbian/" title="Catholic bishops offer &#8220;stunning&#8221; change in beliefs on gays, lesbians">Catholic bishops offer &#8220;stunning&#8221; change...</a></h2>
			</header>

</article>		
	</div>

	</div>


		
					
	<section class="main-box mbt-border-top author-box">

		<h3 class="main-box-title">About the author</h3>

		<div class="main-box-inside">

		<div class="data-image">
			<img src="https://qsaltlake.com/wp-content/uploads/2010/06/hobdaySexy2-222x180.jpg" width="112" height="91" alt="Tony Hobday" class="avatar avatar-112 wp-user-avatar wp-user-avatar-112 alignnone photo" />		</div>
		
		<div class="data-content">
			<h4 class="author-title">Tony Hobday</h4>
			<div class="data-entry-content">
							</div>
		</div>

		</div>

		<div class="vce-content-outside">
			<div class="data-links">
					<a href="https://qsaltlake.com/news/author/tony-hobday/" class="vce-author-link vce-button">View all posts</a>
			</div>
			<div class="vce-author-links">
				 <a href="http://qsaltlake.com" target="_blank" class="fa fa-link vce-author-website"></a>							
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
												
									
			</div>
		</div>

	</section>

		
		
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/news/2017/09/06/unknown-suspect-murder-jamaicas-face-pride-activist-face-charges/#respond" style="display:none;">X</a></small></h3><p class="must-log-in">You must be <a href="https://qsaltlake.com/wp-login.php?redirect_to=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2017%2F09%2F06%2Funknown-suspect-murder-jamaicas-face-pride-activist-face-charges%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
	</div>

		<aside id="sidebar" class="sidebar right">
		<div id="mks_ads_widget-5" class="widget mks_ads_widget"><h4 class="widget-title">Online Edition</h4>			
					
						
			
			<ul class="mks_adswidget_ul custom">
	     			     				     						     		<li data-showind="0">
			     			<a href="https://qsaltlake.com/current-q/" target="_blank" >
			     				<img src="https://qsaltlake.com/wp-content/uploads/2017/08/1709_cover_300.jpg" alt="1709_cover_300.jpg" style="width:257px; height:318px;" width="257"  height="318"/>
			     			</a>
			     		</li>
		     			     			     			    	</ul>
	    
	    	  
	  		  
    	
		</div><div id="mks_ads_widget-1" class="widget mks_ads_widget">			
					
						
			
			<ul class="mks_adswidget_ul large">
	     			     				     						     					     			<li data-showind="0">
				     			<div style="width:300px; height:250px;" width="300"  height="250">
				     				<div style="margin-right: 9px; " id="qsalt-1300784418"><a href="http://biggayfunbus.com/" target="_blank"><img width="350" height="250" src='https://qsaltlake.com/wp-content/uploads/2017/08/BigGayFunBus_350.gif' alt='' title='BigGayFunBus_350' /></a></div>	
				     			</div>
				     		</li>
			     				     			     			     			    	</ul>
	    
	    	  
	  		  
    	
		</div><div id="vce_posts_widget-2" class="widget vce_posts_widget"><h4 class="widget-title">Featured Posts</h4>
		
		<ul class="vce-post-slider" data-autoplay="">

			
		 		<li>
		 					 			
		 			<a href="https://qsaltlake.com/news/2017/09/05/university-utah-pride-week-sept-30-oct-5/" class="featured_image_sidebar" title="University of Utah Pride Week is Sept. 30 through Oct. 5"><span class="vce-post-img"><img width="380" height="260" src="https://qsaltlake.com/wp-content/uploads/2017/09/UnivofUtahPride-380x260.jpg" class="attachment-vce-fa-grid size-vce-fa-grid wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2017/09/UnivofUtahPride-380x260.jpg 380w, https://qsaltlake.com/wp-content/uploads/2017/09/UnivofUtahPride-145x100.jpg 145w" sizes="(max-width: 380px) 100vw, 380px" /></span></a>
		 			<div class="vce-posts-wrap">
		 							 			<a href="https://qsaltlake.com/news/2017/09/05/university-utah-pride-week-sept-30-oct-5/" title="University of Utah Pride Week is Sept. 30 through Oct. 5" class="vce-post-link">University of Utah Pride Week is Sept. 30 through...</a>
			 						 				<div class="entry-meta"><div class="meta-item rtime">2 min read</div></div>
			 					 			</div>
		 		</li>
			
		 		<li>
		 					 			
		 			<a href="https://qsaltlake.com/news/2017/08/31/encircle-provo-lgbt-resource-center-releases-new-mission-video/" class="featured_image_sidebar" title="Encircle Provo LGBT resource center releases new mission video"><span class="vce-post-img"><img width="380" height="260" src="https://qsaltlake.com/wp-content/uploads/2017/08/Encircle-380x260.jpg" class="attachment-vce-fa-grid size-vce-fa-grid wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2017/08/Encircle-380x260.jpg 380w, https://qsaltlake.com/wp-content/uploads/2017/08/Encircle-145x100.jpg 145w" sizes="(max-width: 380px) 100vw, 380px" /></span></a>
		 			<div class="vce-posts-wrap">
		 							 			<a href="https://qsaltlake.com/news/2017/08/31/encircle-provo-lgbt-resource-center-releases-new-mission-video/" title="Encircle Provo LGBT resource center releases new mission video" class="vce-post-link">Encircle Provo LGBT resource center releases new...</a>
			 						 				<div class="entry-meta"><div class="meta-item rtime">1 min read</div></div>
			 					 			</div>
		 		</li>
			
		 		<li>
		 					 			
		 			<a href="https://qsaltlake.com/news/2017/08/29/utah-misses-grade-lgbtq-friendly-campuses/" class="featured_image_sidebar" title="Utah misses the grade on LGBTQ-friendly campuses"><span class="vce-post-img"><img width="380" height="260" src="https://qsaltlake.com/wp-content/uploads/2017/08/pridecampus-380x260.jpg" class="attachment-vce-fa-grid size-vce-fa-grid wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2017/08/pridecampus-380x260.jpg 380w, https://qsaltlake.com/wp-content/uploads/2017/08/pridecampus-145x100.jpg 145w" sizes="(max-width: 380px) 100vw, 380px" /></span></a>
		 			<div class="vce-posts-wrap">
		 							 			<a href="https://qsaltlake.com/news/2017/08/29/utah-misses-grade-lgbtq-friendly-campuses/" title="Utah misses the grade on LGBTQ-friendly campuses" class="vce-post-link">Utah misses the grade on LGBTQ-friendly campuses</a>
			 						 				<div class="entry-meta"><div class="meta-item rtime">2 min read</div></div>
			 					 			</div>
		 		</li>
			
		  </ul>
		
		
		</div><div id="mks_ads_widget-4" class="widget mks_ads_widget"><h4 class="widget-title">Support our sponsors</h4>			
					
						
			
			<ul class="mks_adswidget_ul small">
	     			     				     						     					     			<li data-showind="0">
				     			<div style="width:125px; height:125px;" width="125"  height="125">
				     				<a href="https://qpages.com/item/thomas-travel-agents-vacations/" target="_blank"><img width="125" height="125" src='https://qsaltlake.com/wp-content/uploads/2017/08/ThomasTravel125.jpg' alt='' title='ThomasTravel125' /></a>	
				     			</div>
				     		</li>
			     				     			     			     			     				     						     					     			<li data-showind="0">
				     			<div style="width:125px; height:125px;" width="125"  height="125">
				     				<a href="https://qpages.com/item/lynn-huber/" target="_blank"><img width="125" height="143" src='https://qsaltlake.com/wp-content/uploads/2017/08/HuberAVON_web125.jpg' alt='' title='HuberAVON_web125' /></a>	
				     			</div>
				     		</li>
			     				     			     			     			     				     						     					     			<li data-showind="0">
				     			<div style="width:125px; height:125px;" width="125"  height="125">
				     				<a href="https://qpages.com/item/advanced-awareness-counseling-llc/" target="_blank"><img width="125" height="125" src='https://qsaltlake.com/wp-content/uploads/2017/08/AdvanceCounseling_web125.gif' alt='' title='AdvanceCounseling_web125' /></a>	
				     			</div>
				     		</li>
			     				     			     			     			     				     						     					     			<li data-showind="0">
				     			<div style="width:125px; height:125px;" width="125"  height="125">
				     				<a href="https://qpages.com/item/advanced-awareness-counseling-llc/" target="_blank"><img width="125" height="125" src='https://qsaltlake.com/wp-content/uploads/2017/08/AdvanceCounseling_web125.gif' alt='' title='AdvanceCounseling_web125' /></a>	
				     			</div>
				     		</li>
			     				     			     			     			     				     						     					     			<li data-showind="0">
				     			<div style="width:125px; height:125px;" width="125"  height="125">
				     				<a href="https://qpages.com/item/advanced-awareness-counseling-llc/" target="_blank"><img width="125" height="125" src='https://qsaltlake.com/wp-content/uploads/2017/08/AdvanceCounseling_web125.gif' alt='' title='AdvanceCounseling_web125' /></a>	
				     			</div>
				     		</li>
			     				     			     			     			     				     						     					     			<li data-showind="0">
				     			<div style="width:125px; height:125px;" width="125"  height="125">
				     				<a href="https://qpages.com/item/diverse-diva/" target="_blank"><img width="125" height="125" src='https://qsaltlake.com/wp-content/uploads/2017/08/DiverseDiva_web125.jpg' alt='' title='DiverseDiva_web125' /></a>	
				     			</div>
				     		</li>
			     				     			     			     			     				     						     					     			<li data-showind="0">
				     			<div style="width:125px; height:125px;" width="125"  height="125">
				     				<a href="https://qpages.com/item/thomas-travel-agents-vacations/" target="_blank"><img width="125" height="125" src='https://qsaltlake.com/wp-content/uploads/2017/08/ThomasTravel125.jpg' alt='' title='ThomasTravel125' /></a>	
				     			</div>
				     		</li>
			     				     			     			     			     				     						     					     			<li data-showind="0">
				     			<div style="width:125px; height:125px;" width="125"  height="125">
				     				<a href="https://qpages.com/item/diverse-diva/" target="_blank"><img width="125" height="125" src='https://qsaltlake.com/wp-content/uploads/2017/08/DiverseDiva_web125.jpg' alt='' title='DiverseDiva_web125' /></a>	
				     			</div>
				     		</li>
			     				     			     			     			    	</ul>
	    
	    	  
	  		  
    	
		</div><div class="vce-sticky"><div id="mks_ads_widget-2" class="widget mks_ads_widget"><h4 class="widget-title">Advertisement</h4>			
					
						
			
			<ul class="mks_adswidget_ul small">
	     			     				     						     					     			<li data-showind="0">
				     			<div style="width:125px; height:125px;" width="125"  height="125">
				     				<a href="https://qpages.com/item/djpauly-entertainment/" target="_blank"><img width="125" height="125" src='https://qsaltlake.com/wp-content/uploads/2017/08/DJPauly_web125.gif' alt='' title='DJPauly_web125' /></a>	
				     			</div>
				     		</li>
			     				     			     			     			     				     						     					     			<li data-showind="0">
				     			<div style="width:125px; height:125px;" width="125"  height="125">
				     				<a href="https://qpages.com/item/advanced-awareness-counseling-llc/" target="_blank"><img width="125" height="125" src='https://qsaltlake.com/wp-content/uploads/2017/08/AdvanceCounseling_web125.gif' alt='' title='AdvanceCounseling_web125' /></a>	
				     			</div>
				     		</li>
			     				     			     			     			     				     						     					     			<li data-showind="0">
				     			<div style="width:125px; height:125px;" width="125"  height="125">
				     				<a href="https://www.facebook.com/troy.hunter.716" target="_blank"><img width="145" height="181" src='https://qsaltlake.com/wp-content/uploads/2017/08/AlohaBodyWorks_145x181.jpg' alt='' title='AlohaBodyWorks_145x181' /></a>	
				     			</div>
				     		</li>
			     				     			     			     			     				     						     					     			<li data-showind="0">
				     			<div style="width:125px; height:125px;" width="125"  height="125">
				     				<div style="margin-top: 1px; margin-right: 1px; margin-left: 1px; " id="qsalt-859725021"><a href="https://qpages.com/item/lgbtq-affirmative-psychotherapists-guild-of-utah-counselors-organizations/" target="_blank"><img width="125" height="125" src='https://qsaltlake.com/wp-content/uploads/2017/08/LGBTQTherapist_web125.gif' alt='' title='LGBTQTherapist_web125' /></a></div>	
				     			</div>
				     		</li>
			     				     			     			     			    	</ul>
	    
	    	  
	  		  
    	
		</div></div>	</aside>

</div>




	<footer id="footer" class="site-footer">

				<div class="container">
			<div class="container-fix">
										<div class="bit-3">
					<div id="vce_posts_widget-10" class="widget vce_posts_widget"><h4 class="widget-title">Most Popular</h4>
		
		<ul class="vce-post-list" data-autoplay="">

			
		 		<li>
		 					 			
		 			<a href="https://qsaltlake.com/news/2014/08/05/byu-listed-fourth-gay-unfriendly-university-america/" class="featured_image_sidebar" title="Movin&#8217; on up: BYU moves from 6th to 4th most &#8220;gay-unfriendly&#8221; university in America"><span class="vce-post-img"><img width="145" height="100" src="https://qsaltlake.com/wp-content/uploads/2014/08/byu.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2014/08/byu.jpg 587w, https://qsaltlake.com/wp-content/uploads/2014/08/byu-300x204.jpg 300w, https://qsaltlake.com/wp-content/uploads/2014/08/byu-468x318.jpg 468w, https://qsaltlake.com/wp-content/uploads/2014/08/byu-280x192.jpg 280w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
		 			<div class="vce-posts-wrap">
		 							 			<a href="https://qsaltlake.com/news/2014/08/05/byu-listed-fourth-gay-unfriendly-university-america/" title="Movin&#8217; on up: BYU moves from 6th to 4th most &#8220;gay-unfriendly&#8221; university in America" class="vce-post-link">Movin&#8217; on up: BYU moves from 6th to 4th most...</a>
			 					 			</div>
		 		</li>
			
		 		<li>
		 					 			
		 			<a href="https://qsaltlake.com/news/2013/12/23/state-files-another-emergency-motion-stay-sex-marriage-ruling/" class="featured_image_sidebar" title="State files another emergency motion to stay same-sex marriage ruling"><span class="vce-post-img"><img width="145" height="100" src="https://qsaltlake.com/wp-content/uploads/2017/08/NoPic-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2017/08/NoPic-145x100.jpg 145w, https://qsaltlake.com/wp-content/uploads/2017/08/NoPic-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
		 			<div class="vce-posts-wrap">
		 							 			<a href="https://qsaltlake.com/news/2013/12/23/state-files-another-emergency-motion-stay-sex-marriage-ruling/" title="State files another emergency motion to stay same-sex marriage ruling" class="vce-post-link">State files another emergency motion to stay same...</a>
			 					 			</div>
		 		</li>
			
		 		<li>
		 					 			
		 			<a href="https://qsaltlake.com/news/2013/07/02/lisonbee-weber-state-packer-fired/" class="featured_image_sidebar" title="WSU professor fired after objecting to Packer Center naming"><span class="vce-post-img"><img width="75" height="100" src="https://qsaltlake.com/wp-content/uploads/2013/07/Lisonbee-1.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2013/07/Lisonbee-1.jpg 300w, https://qsaltlake.com/wp-content/uploads/2013/07/Lisonbee-1-225x300.jpg 225w" sizes="(max-width: 75px) 100vw, 75px" /></span></a>
		 			<div class="vce-posts-wrap">
		 							 			<a href="https://qsaltlake.com/news/2013/07/02/lisonbee-weber-state-packer-fired/" title="WSU professor fired after objecting to Packer Center naming" class="vce-post-link">WSU professor fired after objecting to Packer Center...</a>
			 					 			</div>
		 		</li>
			
		 		<li>
		 					 			
		 			<a href="https://qsaltlake.com/news/2010/05/14/straight-ally-faces-legal-battle/" class="featured_image_sidebar" title="Straight Ally Comes to Lesbian&#8217;s Aid at Prop 8 Rally, Faces 18-Month Legal Battle"><span class="vce-post-img"><img width="145" height="100" src="https://qsaltlake.com/wp-content/uploads/2017/08/NoPic-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2017/08/NoPic-145x100.jpg 145w, https://qsaltlake.com/wp-content/uploads/2017/08/NoPic-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
		 			<div class="vce-posts-wrap">
		 							 			<a href="https://qsaltlake.com/news/2010/05/14/straight-ally-faces-legal-battle/" title="Straight Ally Comes to Lesbian&#8217;s Aid at Prop 8 Rally, Faces 18-Month Legal Battle" class="vce-post-link">Straight Ally Comes to Lesbian&#8217;s Aid at Prop 8...</a>
			 					 			</div>
		 		</li>
			
		  </ul>
		
		
		</div>				</div>
							<div class="bit-3">
					<div id="vce_posts_widget-11" class="widget vce_posts_widget"><h4 class="widget-title">Talked About</h4>
		
		<ul class="vce-post-list" data-autoplay="">

			
		 		<li>
		 					 			
		 			<a href="https://qsaltlake.com/news/2012/10/16/anti-gay-group-releases-ad-comparing-homosexuality-to-pedophilia/" class="featured_image_sidebar" title="Anti-gay group releases ad comparing homosexuality to pedophilia"><span class="vce-post-img"><img width="145" height="100" src="https://qsaltlake.com/wp-content/uploads/2017/08/brianbrown-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2017/08/brianbrown-145x100.jpg 145w, https://qsaltlake.com/wp-content/uploads/2017/08/brianbrown-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
		 			<div class="vce-posts-wrap">
		 							 			<a href="https://qsaltlake.com/news/2012/10/16/anti-gay-group-releases-ad-comparing-homosexuality-to-pedophilia/" title="Anti-gay group releases ad comparing homosexuality to pedophilia" class="vce-post-link">Anti-gay group releases ad comparing homosexuality...</a>
			 					 			</div>
		 		</li>
			
		 		<li>
		 					 			
		 			<a href="https://qsaltlake.com/news/2015/06/11/young-delta-utah-man-robbed-had-die-fag-carved-into-his-arms-forced-to-drink-bleach/" class="featured_image_sidebar" title="Young Delta, Utah man robbed, had &#8216;Die Fag&#8217; carved into his arm, forced to drink bleach"><span class="vce-post-img"><img width="145" height="64" src="https://qsaltlake.com/wp-content/uploads/2015/06/RickyJonesDelta.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2015/06/RickyJonesDelta.jpg 720w, https://qsaltlake.com/wp-content/uploads/2015/06/RickyJonesDelta-300x133.jpg 300w, https://qsaltlake.com/wp-content/uploads/2015/06/RickyJonesDelta-468x208.jpg 468w, https://qsaltlake.com/wp-content/uploads/2015/06/RickyJonesDelta-600x267.jpg 600w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
		 			<div class="vce-posts-wrap">
		 							 			<a href="https://qsaltlake.com/news/2015/06/11/young-delta-utah-man-robbed-had-die-fag-carved-into-his-arms-forced-to-drink-bleach/" title="Young Delta, Utah man robbed, had &#8216;Die Fag&#8217; carved into his arm, forced to drink bleach" class="vce-post-link">Young Delta, Utah man robbed, had &#8216;Die...</a>
			 					 			</div>
		 		</li>
			
		 		<li>
		 					 			
		 			<a href="https://qsaltlake.com/news/2014/08/13/facebook-donates-10000-reyes-campaign/" class="featured_image_sidebar" title="Facebook donates $10,000 to Reyes&#8217; campaign"><span class="vce-post-img"><img width="145" height="81" src="https://qsaltlake.com/wp-content/uploads/2014/08/reyes_zuckerberg.png" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2014/08/reyes_zuckerberg.png 1919w, https://qsaltlake.com/wp-content/uploads/2014/08/reyes_zuckerberg-300x168.png 300w, https://qsaltlake.com/wp-content/uploads/2014/08/reyes_zuckerberg-468x262.png 468w, https://qsaltlake.com/wp-content/uploads/2014/08/reyes_zuckerberg-600x337.png 600w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
		 			<div class="vce-posts-wrap">
		 							 			<a href="https://qsaltlake.com/news/2014/08/13/facebook-donates-10000-reyes-campaign/" title="Facebook donates $10,000 to Reyes&#8217; campaign" class="vce-post-link">Facebook donates $10,000 to Reyes&#8217; campaign</a>
			 					 			</div>
		 		</li>
			
		 		<li>
		 					 			
		 			<a href="https://qsaltlake.com/news/2013/10/28/utah-pride-center-lays-workers-kills-sage-program/" class="featured_image_sidebar" title="Breaking News: Utah Pride Center lays off workers, cuts salaries"><span class="vce-post-img"><img width="145" height="80" src="https://qsaltlake.com/wp-content/uploads/2013/10/UtahPrideCenter.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://qsaltlake.com/wp-content/uploads/2013/10/UtahPrideCenter.jpg 945w, https://qsaltlake.com/wp-content/uploads/2013/10/UtahPrideCenter-300x165.jpg 300w, https://qsaltlake.com/wp-content/uploads/2013/10/UtahPrideCenter-468x257.jpg 468w, https://qsaltlake.com/wp-content/uploads/2013/10/UtahPrideCenter-600x330.jpg 600w" sizes="(max-width: 145px) 100vw, 145px" /></span></a>
		 			<div class="vce-posts-wrap">
		 							 			<a href="https://qsaltlake.com/news/2013/10/28/utah-pride-center-lays-workers-kills-sage-program/" title="Breaking News: Utah Pride Center lays off workers, cuts salaries" class="vce-post-link">Breaking News: Utah Pride Center lays off workers...</a>
			 					 			</div>
		 		</li>
			
		  </ul>
		
		
		</div>				</div>
							<div class="bit-3">
					<div id="vce_video_widget-2" class="widget vce_video_widget"><h4 class="widget-title">Video of the Day</h4>		<div class="video-widget-inside">
		
			
						
				<iframe width="100%" height="150" src="https://www.youtube.com/embed/XsEMu5UCy0g?showinfo=0;controls=0" frameborder="0" allowfullscreen></iframe>
			
						
				
				
		<div class="clear"></div>
		
		</div>
		
		</div><div id="mks_social_widget-2" class="widget mks_social_widget"><h4 class="widget-title">Join Us</h4>		
				
							<ul class="mks_social_widget_ul">
		  			  		<li><a href="#" class="instagram_ico soc_rounded" target="_blank" style="width: 47px; height: 47px; font-size: 16px;"><span>instagram</span></a></li>
		  			  		<li><a href="#" class="twitter_ico soc_rounded" target="_blank" style="width: 47px; height: 47px; font-size: 16px;"><span>twitter</span></a></li>
		  			  		<li><a href="#" class="facebook_ico soc_rounded" target="_blank" style="width: 47px; height: 47px; font-size: 16px;"><span>facebook</span></a></li>
		  			  		<li><a href="#" class="googleplus_ico soc_rounded" target="_blank" style="width: 47px; height: 47px; font-size: 16px;"><span>googleplus</span></a></li>
		  			  		<li><a href="#" class="pinterest_ico soc_rounded" target="_blank" style="width: 47px; height: 47px; font-size: 16px;"><span>pinterest</span></a></li>
		  			  		<li><a href="#" class="rss_ico soc_rounded" target="_blank" style="width: 47px; height: 47px; font-size: 16px;"><span>rss</span></a></li>
		  			  </ul>
		

		</div>				</div>
						</div>
		</div>
		
					<div class="container-full site-info">
				<div class="container">
											<div class="vce-wrap-left">
							<p>Copyright &copy; 2014. Created by <a href="http://mekshq.com" target="_blank">Meks</a>. Powered by <a href="http://www.wordpress.org" target="_blank">WordPress</a>.</p>						</div>
					
											<div class="vce-wrap-right">
								<ul id="vce_footer_menu" class="bottom-nav-menu"><li id="menu-item-19427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19427"><a href="https://qsaltlake.com/about/">About Us</a></li>
<li id="menu-item-19428" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19428"><a href="https://qsaltlake.com/about/advertising/">Advertising</a></li>
<li id="menu-item-19429" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19429"><a href="https://qsaltlake.com/about/contact-us/">Contact Us</a></li>
<li id="menu-item-19426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19426"><a href="https://qsaltlake.com/classifieds/">Classifieds</a></li>
<li id="menu-item-19430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19430"><a href="https://qsaltlake.com/about/privacy/">Privacy</a></li>
</ul>						</div>
						

					
			
				</div>
			</div>
		

	</footer>


</div>
</div>

<a href="javascript:void(0)" id="back-top"><i class="fa fa-angle-up"></i></a>

 <script type="text/javascript">
  analytics.track("Viewed Post", {"title":"Man charged with murder of Jamaica&#8217;s &#8220;The Face of Pride,&#8221; Dexter Pottinger","category":"World","noninteraction":true}, {"library":"analytics-wordpress"});
    
</script>
<script type="text/javascript">/* <![CDATA[ */ jQuery(document).ready( function() { jQuery.post( "https://qsaltlake.com/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "169e2fceca", post_id : 42333 } ); } ); /* ]]> */</script>
<script type='text/javascript' src='https://qsaltlake.com/wp-content/plugins/mailpoet/assets/js/vendor.f8675e02.js?ver=3.0.0-rc.2.0.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var MailPoetForm = {"ajax_url":"https:\/\/qsaltlake.com\/wp-admin\/admin-ajax.php","is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://qsaltlake.com/wp-content/plugins/mailpoet/assets/js/public.17607eba.js?ver=3.0.0-rc.2.0.2'></script>
<script type='text/javascript'>
function initMailpoetTranslation() {
  if(typeof MailPoet !== 'undefined') {
    MailPoet.I18n.add('ajaxFailedErrorMessage', 'An error has happened while performing a request, please try again later.')
  } else {
    setTimeout(initMailpoetTranslation, 250);
  }
}
setTimeout(initMailpoetTranslation, 250);
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/qsaltlake.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://qsaltlake.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var vce_js_settings = {"sticky_header":"1","sticky_header_offset":"700","sticky_header_logo":"https:\/\/qsaltlake.com\/wp-content\/uploads\/2017\/08\/qsl_logo_small.png","logo":"https:\/\/qsaltlake.com\/wp-content\/uploads\/2017\/08\/QSaltLakeMasthead.png","logo_retina":"","logo_mobile":"","logo_mobile_retina":"","rtl_mode":"0","ajax_url":"https:\/\/qsaltlake.com\/wp-admin\/admin-ajax.php","ajax_mega_menu":"1","mega_menu_slider":"","mega_menu_subcats":"","lay_fa_grid_center":"","full_slider_autoplay":"","grid_slider_autoplay":"","fa_big_opacity":{"1":"0.5","2":"0.7"},"top_bar_mobile":"1","top_bar_mobile_group":"","top_bar_more_link":"More"};
/* ]]> */
</script>
<script type='text/javascript' src='https://qsaltlake.com/wp-content/themes/voice/js/min.js?ver=2.5'></script>
<script type='text/javascript' src='https://qsaltlake.com/wp-includes/js/wp-embed.min.js?ver=f2f7d84449e45f8087f27b4cb05bc2e7'></script>
<script>
jQuery( document ).ready( function($) {
	$('.bawpvc-ajax-counter').each( function( i ) {
		var $id = $(this).data('id');
		var t = this;
		var n = 1;
		$.get('https://qsaltlake.com/wp-admin/admin-ajax.php?action=bawpvc-ajax-counter&p='+$id+'&n='+n, function( html ) {
			$(t).html( html );
		})
	});
});
</script>

</body>
</html>