<!DOCTYPE html>
<!--[if IE 8]><html
class="ie8"><![endif]-->
<!--[if IE 9]><html
class="ie9"><![endif]-->
<!--[if gt IE 8]><!--><html
lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]--><head><link
rel="stylesheet" type="text/css" href="https://qsaltlake.com/wp-content/cache/minify/67e07.default.include.848c6b.css" media="all" /> <script type="text/javascript" src="https://qsaltlake.com/wp-content/cache/minify/67e07.default.include.752be8.js"></script> <meta
http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta
name="viewport" content="user-scalable=yes, width=device-width, initial-scale=1.0, maximum-scale=1, minimum-scale=1"><meta
name="description" content="Utah's news and entertainment magazine for the lesbian, gay, bisexual, transgender and ally community" /><!--[if lt IE 9]> <script src="https://qsaltlake.com/wp-content/themes/voice/js/html5.js"></script> <![endif]--><title>album-release slate this year includes new Brandi Carlile, Robyn, Britney</title><meta
name="description" content="album-release slate this year includes new Brandi Carlile, Robyn, Britney, Kacey, and more"/><link
rel="canonical" href="https://qsaltlake.com/news/2018/04/30/album-release-slate/" /><link
rel="publisher" href="https://plus.google.com/113070347121609191291/about"/><meta
property="og:locale" content="en_US" /><meta
property="og:type" content="article" /><meta
property="og:title" content="album-release slate this year includes new Brandi Carlile, Robyn, Britney" /><meta
property="og:description" content="album-release slate this year includes new Brandi Carlile, Robyn, Britney, Kacey, and more" /><meta
property="og:url" content="https://qsaltlake.com/news/2018/04/30/album-release-slate/" /><meta
property="og:site_name" content="QSaltLake Magazine" /><meta
property="article:publisher" content="https://facebook.com/qsaltlake/" /><meta
property="article:section" content="Hear Me Out" /><meta
property="article:published_time" content="2018-04-30T12:00:12+00:00" /><meta
property="article:modified_time" content="2018-04-30T11:21:29+00:00" /><meta
property="og:updated_time" content="2018-04-30T11:21:29+00:00" /><meta
property="og:image" content="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/29111528/Brandi.jpg" /><meta
property="og:image:secure_url" content="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/29111528/Brandi.jpg" /><meta
property="og:image:width" content="900" /><meta
property="og:image:height" content="400" /><link
rel='dns-prefetch' href='//fonts.googleapis.com' /><link
rel='dns-prefetch' href='//s.w.org' /><link
rel="alternate" type="application/rss+xml" title="QSaltLake Magazine &raquo; Feed" href="https://qsaltlake.com/feed/" /><link
rel="alternate" type="application/rss+xml" title="QSaltLake Magazine &raquo; Comments Feed" href="https://qsaltlake.com/comments/feed/" /><link
rel="alternate" type="application/rss+xml" title="QSaltLake Magazine &raquo; 7 albums (Britney! Robyn!) that will make this year suck less Comments Feed" href="https://qsaltlake.com/news/2018/04/30/album-release-slate/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/qsaltlake.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=d2b2817b2c1490e31e283aec8dae7bd0"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <script>/*<![CDATA[*/advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();/*]]>*/</script><style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link
rel='stylesheet' id='contact-form-7-css'  href='https://qsaltlake.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.1' type='text/css' media='all' /><link
rel='stylesheet' id='vce_font_0-css'  href='https://fonts.googleapis.com/css?family=Work+Sans%3A400%2C800%2C600&#038;subset=latin%2Clatin-ext&#038;ver=2.5' type='text/css' media='screen' /><style id='vce_style-inline-css' type='text/css'>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</style><link
rel='stylesheet' id='awpcp-frontend-style-css'  href='https://qsaltlake.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css?ver=3.8.3' type='text/css' media='all' />
<!--[if lte IE 6]><link
rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='https://qsaltlake.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css?ver=3.8.3' type='text/css' media='all' />
<![endif]-->
<!--[if lte IE 7]><link
rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='https://qsaltlake.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css?ver=3.8.3' type='text/css' media='all' />
<![endif]--> <script type='text/javascript' src='https://qsaltlake.com/wp-content/plugins/meks-flexible-shortcodes/js/main.js?ver=1.3.1'></script> <script type='text/javascript' src='https://qsaltlake.com/wp-content/uploads/134/882/public/assets/js/advanced.js?ver=1.8.28'></script> <script type='text/javascript'>var advanced_ads_responsive={"reload_on_resize":"0"};</script> <script type='text/javascript' src='https://qsaltlake.com/wp-content/uploads/134/703/public/assets/js/62.js?ver=1.7.2'></script> <script type='text/javascript' src='https://qsaltlake.com/wp-content/uploads/134/289/591/197/assets/js/899.js?ver=2.1.3'></script> <script type="text/javascript">/*<![CDATA[*/!function(){var analytics=window.analytics=window.analytics||[];if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.0";window.analytics.load("7dsXK8yjQEOYBJ9b7aXgPcJ1v3NeLcsF");window.analytics.page();}}();/*]]>*/</script> <link
rel='https://api.w.org/' href='https://qsaltlake.com/wp-json/' /><link
rel="EditURI" type="application/rsd+xml" title="RSD" href="https://qsaltlake.com/xmlrpc.php?rsd" /><link
rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://qsaltlake.com/wp-includes/wlwmanifest.xml" /><link
rel='shortlink' href='https://qsaltlake.com/?p=47159' /><link
rel="alternate" type="application/json+oembed" href="https://qsaltlake.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2018%2F04%2F30%2Falbum-release-slate%2F" /><link
rel="alternate" type="text/xml+oembed" href="https://qsaltlake.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2018%2F04%2F30%2Falbum-release-slate%2F&#038;format=xml" /> <script type="text/javascript">var _statcounter=_statcounter||[];_statcounter.push({"tags":{"author":"Chris Azzopardi"}});</script>  <script>var sc_project=6082424;var sc_security="0d5c72ba";var sc_invisible=1;var scJsHost=(("https:"==document.location.protocol)?"https://secure.":"http://www.");</script> <script type="text/javascript"
				src="https://secure.statcounter.com/counter/counter.js"
				async></script> <noscript><div
class="statcounter"><a
title="web analytics" href="https://statcounter.com/"><img
class="statcounter" src="https://c.statcounter.com/6082424/0/0d5c72ba/1/" alt="web analytics" /></a></div></noscript>
 <script type="text/javascript">/*<![CDATA[*/(function(url){if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){return;}
var addEvent=function(evt,handler){if(window.addEventListener){document.addEventListener(evt,handler,false);}else if(window.attachEvent){document.attachEvent('on'+evt,handler);}};var removeEvent=function(evt,handler){if(window.removeEventListener){document.removeEventListener(evt,handler,false);}else if(window.detachEvent){document.detachEvent('on'+evt,handler);}};var evts='contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');var logHuman=function(){var wfscr=document.createElement('script');wfscr.type='text/javascript';wfscr.async=true;wfscr.src=url+'&r='+Math.random();(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);for(var i=0;i<evts.length;i++){removeEvent(evts[i],logHuman);}};for(var i=0;i<evts.length;i++){addEvent(evts[i],logHuman);}})('//qsaltlake.com/?wordfence_lh=1&hid=7C0545D559EC6954041701048CBE033C');/*]]>*/</script><script>advads_items={conditions:{},display_callbacks:{},display_effect_callbacks:{},hide_callbacks:{},backgrounds:{},effect_durations:{},close_functions:{},showed:[]};</script><script type="text/javascript">;var advadsCfpQueue=[],advadsCfpExpHours=3;var advadsCfpClickLimit=3;;var advadsCfpPath='';var advadsCfpDomain='';var advadsCfpAd=function(adID){if('undefined'==typeof advadsProCfp){advadsCfpQueue.push(adID)}else{advadsProCfp.addElement(adID)}};</script> <style type="text/css">.recentcomments
a{display:inline !important;padding:0
!important;margin:0
!important}</style><link
rel="amphtml" href="https://qsaltlake.com/news/2018/04/30/album-release-slate/amp/"><link
rel="icon" href="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05163059/cropped-Q_bug-300x300.png" sizes="32x32" /><link
rel="icon" href="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05163059/cropped-Q_bug-300x300.png" sizes="192x192" /><link
rel="apple-touch-icon-precomposed" href="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05163059/cropped-Q_bug-300x300.png" /><meta
name="msapplication-TileImage" content="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05163059/cropped-Q_bug-300x300.png" /><link
rel="shortcut icon" href="https://qsaltlake.com/wp-content/uploads/2017/08/cropped-Q_bug.png" type="image/x-icon" /></head><body
class="post-template-default single single-post postid-47159 single-format-standard unknown vce-sid-right"><div
id="vce-main"><header
id="header" class="main-header"><div
class="top-header"><div
class="container"><div
class="vce-wrap-left"><ul
id="vce_top_navigation_menu" class="top-nav-menu"><li
id="menu-item-30137" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30137"><a
href="https://qsaltlake.com/subscribe-2/">Subscribe</a></li><li
id="menu-item-30138" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30138"><a
title="Gay Salt Lake Business Directory" href="https://qsaltlake.com/business-directory/">QPages</a></li><li
id="menu-item-30139" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30139"><a
href="https://qsaltlake.com/classifieds/browse-classifieds/">Classifieds</a></li></ul></div><div
class="vce-wrap-right"><div
class="menu-social-media-menu-container"><ul
id="vce_social_menu" class="soc-nav-menu"><li
id="menu-item-41777" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41777"><a
href="https://facebook.com/qsaltlake/"><span
class="vce-social-name">Facebook</span></a></li><li
id="menu-item-41778" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41778"><a
href="https://twitter.com/QSaltLake"><span
class="vce-social-name">Twitter</span></a></li><li
id="menu-item-41779" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41779"><a
href="https://www.instagram.com/qsaltlake/"><span
class="vce-social-name">Instagram</span></a></li><li
id="menu-item-41780" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41780"><a
href="https://www.linkedin.com/company/qsaltlake"><span
class="vce-social-name">LinkedIn</span></a></li><li
id="menu-item-41781" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41781"><a
href="https://plus.google.com/113070347121609191291"><span
class="vce-social-name">Google+</span></a></li><li
id="menu-item-41782" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41782"><a
href="https://www.youtube.com/user/QSaltLake"><span
class="vce-social-name">YouTube</span></a></li><li
id="menu-item-41783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41783"><a
href="https://www.pinterest.com/qsaltlake/"><span
class="vce-social-name">Pinterest</span></a></li></ul></div></div></div></div><div
class="container header-2-wrapper header-main-area"><div
class="vce-res-nav">
<a
class="vce-responsive-nav" href="#sidr-main"><i
class="fa fa-bars"></i></a></div><div
class="site-branding">
<span
class="site-title">
<a
href="https://qsaltlake.com/" title="QSaltLake Magazine" class="has-logo"><img
src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05163103/QSaltLakeMasthead.png" alt="QSaltLake Magazine" /></a>
</span><span
class="site-description">Utah LGBT news, bars, views, arts</span></div><div
class="vce-header-ads"><div
style="margin-right: 9px; " id="qsalt-949589345"><a
data-bid="1" href="https://qsaltlake.com/linkout/46959" rel="nofollow" target="_blank"><img
width="728" height="90" src='https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/20110759/QualityFlowers_banner_728.jpg' alt='' title='QualityFlowers_banner_728'  style=" max-width: 100%; height: auto;"/></a></div></div></div><div
class="header-bottom-wrapper header-left-nav"><div
class="container">
<nav
id="site-navigation" class="main-navigation" role="navigation"><ul
id="vce_main_navigation_menu" class="nav-menu"><li
id="menu-item-41844" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-41844"><a
href="https://qsaltlake.com/">Home</a><li
id="menu-item-30165" class="red menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30165 vce-cat-3"><a
href="https://qsaltlake.com/news/category/news/">News</a><ul
class="sub-menu"><li
id="menu-item-30170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30170 vce-cat-4"><a
href="https://qsaltlake.com/news/category/news/local/">Local</a><li
id="menu-item-30171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30171 vce-cat-5"><a
href="https://qsaltlake.com/news/category/news/national/">National</a><li
id="menu-item-30172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30172 vce-cat-41"><a
href="https://qsaltlake.com/news/category/news/world/">World</a></ul><li
id="menu-item-30203" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30203 vce-cat-138"><a
href="https://qsaltlake.com/news/category/features/history/">LGBT History Month</a><li
id="menu-item-30164" class="orange menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30164 vce-cat-20"><a
href="https://qsaltlake.com/news/category/features/">Features</a><ul
class="sub-menu"><li
id="menu-item-30202" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30202 vce-cat-119"><a
href="https://qsaltlake.com/news/category/features/feature-stories/">Feature Stories</a><li
id="menu-item-30201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30201 vce-cat-53"><a
href="https://qsaltlake.com/news/category/features/fabulous-people/">Fabulous People</a><li
id="menu-item-30200" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30200 vce-cat-137"><a
href="https://qsaltlake.com/news/category/nightlife/fashion/">Fashion</a><li
id="menu-item-30206" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30206 vce-cat-127"><a
href="https://qsaltlake.com/news/category/features/travel/">Travel</a><li
id="menu-item-30168" class="blue menu-item menu-item-type-taxonomy menu-item-object-post_format menu-item-30168"><a
href="https://qsaltlake.com/news/type/video/">Video</a></ul><li
id="menu-item-30166" class="yellow menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-30166 vce-cat-21"><a
href="https://qsaltlake.com/news/category/artsandentertainment/">Arts+Entertainment</a><ul
class="sub-menu"><li
id="menu-item-30173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30173 vce-cat-23"><a
href="https://qsaltlake.com/news/category/artsandentertainment/artsnews/">Arts News</a><li
id="menu-item-30174" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30174 vce-cat-197"><a
href="https://qsaltlake.com/news/category/artsandentertainment/comics/">Comics</a><li
id="menu-item-30176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30176 vce-cat-22"><a
href="https://qsaltlake.com/news/category/artsandentertainment/gayagenda/">Gay Agenda</a><li
id="menu-item-43354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43354 vce-cat-220"><a
href="https://qsaltlake.com/news/category/views/gay-writes/">Gay Writes</a><li
id="menu-item-30175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30175 vce-cat-28"><a
href="https://qsaltlake.com/news/category/artsandentertainment/diningguide/">Dining Guide</a><li
id="menu-item-30177" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-30177 vce-cat-198"><a
href="https://qsaltlake.com/news/category/artsandentertainment/hear-me-out/">Hear Me Out</a><li
id="menu-item-30178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30178 vce-cat-213"><a
href="https://qsaltlake.com/news/category/artsandentertainment/interviews/">Interviews</a><li
id="menu-item-30179" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30179 vce-cat-27"><a
href="https://qsaltlake.com/news/category/artsandentertainment/restaurant/">Restaurant Reviews</a><li
id="menu-item-30180" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30180 vce-cat-38"><a
href="https://qsaltlake.com/news/category/artsandentertainment/reviews/">Reviews</a><li
id="menu-item-34619" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34619 vce-cat-122"><a
href="https://qsaltlake.com/news/category/artsandentertainment/sundance-festival/">Sundance Film Festival</a></ul><li
id="menu-item-30167" class="green menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-30167 vce-cat-7"><a
href="https://qsaltlake.com/news/category/views/">Views</a><ul
class="sub-menu"><li
id="menu-item-30187" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30187 vce-cat-139"><a
href="https://qsaltlake.com/news/category/views/columnists/mr_manners/">Ask Mr. Manners</a><li
id="menu-item-30182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30182 vce-cat-124"><a
href="https://qsaltlake.com/news/category/views/columnists/creep/">Creep of the Week</a><li
id="menu-item-30188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30188 vce-cat-37"><a
href="https://qsaltlake.com/news/category/views/editorial-cartoon/">Editorial Cartoon</a><li
id="menu-item-30189" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30189 vce-cat-36"><a
href="https://qsaltlake.com/news/category/views/guest-editorials/">Guest Editorials</a><li
id="menu-item-30183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30183 vce-cat-15"><a
href="https://qsaltlake.com/news/category/views/columnists/lambdalore/">Lambda Lore</a><li
id="menu-item-30190" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30190 vce-cat-8"><a
href="https://qsaltlake.com/news/category/views/letters/">Letters</a><li
id="menu-item-30184" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30184 vce-cat-10"><a
href="https://qsaltlake.com/news/category/views/columnists/michaelaaron/">Michael Aaron</a><li
id="menu-item-30185" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30185 vce-cat-18"><a
href="https://qsaltlake.com/news/category/views/columnists/health/">Q Health</a><li
id="menu-item-30186" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30186 vce-cat-135"><a
href="https://qsaltlake.com/news/category/views/columnists/queershift/">Queer Shift</a><li
id="menu-item-41449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41449 vce-cat-50"><a
href="https://qsaltlake.com/news/category/views/columnists/the-perils-of-petunia-pap-smear/">The Perils of Petunia Pap Smear</a><li
id="menu-item-30194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30194 vce-cat-13"><a
href="https://qsaltlake.com/news/category/views/columnists/whosyourdaddy/">Who&#8217;s Your Daddy</a></ul><li
id="menu-item-35667" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35667"><a
href="https://qsaltlake.com/current-q/">Online Edition</a><li
class="search-header-wrap"><a
class="search_header" href="javascript:void(0)"><i
class="fa fa-search"></i></a><ul
class="search-header-form-ul"><li><form
class="search-header-form" action="https://qsaltlake.com/" method="get">
<input
name="s" class="search-input" size="20" type="text" value="Type here to search..." onfocus="(this.value == 'Type here to search...') && (this.value = '')" onblur="(this.value == '') && (this.value = 'Type here to search...')" placeholder="Type here to search..." /></form></li></ul></li></ul></nav></div></div></header><div
id="main-wrapper"><div
id="content" class="container site-content vce-sid-right"><div
id="primary" class="vce-main-content"><main
id="main" class="main-box main-box-single">
<article
id="post-47159" class="vce-single post-47159 post type-post status-publish format-standard has-post-thumbnail hentry category-hear-me-out"><header
class="entry-header">
<span
class="meta-category"><a
href="https://qsaltlake.com/news/category/artsandentertainment/hear-me-out/" class="category-198">Hear Me Out</a></span><h1 class="entry-title">7 albums (Britney! Robyn!) that will make this year suck less</h1><div
class="entry-meta"><div
class="meta-item date"><span
class="updated">16 hours ago</span></div><div
class="meta-item comments"><a
href="https://qsaltlake.com/news/2018/04/30/album-release-slate/#respond">Add Comment</a></div><div
class="meta-item author"><span
class="vcard author"><span
class="fn">by <a
href="https://qsaltlake.com/news/author/chris-azzopardi/">Chris Azzopardi</a></span></span></div></div>
</header><div
class="meta-image">
<img
width="810" height="360" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/29111528/Brandi-810x360.jpg" class="attachment-vce-lay-a size-vce-lay-a wp-post-image" alt="" srcset="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/29111528/Brandi-810x360.jpg 810w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/29111528/Brandi-300x133.jpg 300w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/29111528/Brandi-768x341.jpg 768w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/29111528/Brandi-468x208.jpg 468w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/29111528/Brandi.jpg 900w" sizes="(max-width: 810px) 100vw, 810px" /></div><div
class="meta-author"><div
class="meta-author-img"></div><div
class="meta-author-wrapped">Written by <span
class="vcard author"><span
class="fn"><a
href="https://qsaltlake.com/news/author/chris-azzopardi/">Chris Azzopardi</a></span></span></div></div><div
class="entry-content"><p>That Britney album better come quickly — preferably before the world combusts from nuclear warfare. On the horizon of a very gay 2018 outside of Brandi Carlile’s recently released must-hear masterwork? New Robyn, new Kylie, new Troye — if only our current political era were as promising as this year’s album-release slate.</p><h6><strong>Kylie Minogue, <em>Golden</em></strong></h6><p>The cool place to be a gay icon isn’t Los Angeles anymore — it’s Nashville, y’all. There, Kesha found an empowered state of mind for her twice Grammy-nominated album, <em>Rainbow</em>. Cyndi Lauper took a <em>Detour</em>, recording Patsy Cline and Dolly Parton classics for the aforementioned covers disc. Now, as the release date nears for her 14th studio album, add Kylie Minogue to the long list of pop princesses who like a little dirt on the dance floor.</p><div
class="qsalt-injection1" style="float: left; " id="qsalt-2023332962"><a
data-bid="1" href="https://qsaltlake.com/linkout/46961" rel="nofollow" target="_blank"><img
width="300" height="250" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/20110924/QualityFlowers_banner_350.jpg" alt="" title="QualityFlowers_banner_350" style=" max-width: 100%; height: auto;"></a></div><p>The first single “Dancing” stays true to the Aussie diva’s long-established brand of fizzy pop. But before it morphs into a country-lite banger, its opening acoustic guitar licks trick you into thinking her boots — okay, very bedazzled pumps — were made for walking, when all Kylie wants to do is dance away her relationship woes. Revealing that her breakup with former fiancé Joshua Sasse influenced her new works, she told <em>The Sun</em> in October 2017, “The songs are very storytelling and story-based.” Lovers, will this be the Joni Mitchell album we never knew we needed from our <em>Golden</em> girl?</p><h6><strong> <em>Love, Simon</em> soundtrack</strong></h6><p>There’s no denying the power of song in a coming-of-age film. For example, John Hughes classics like <em>The Breakfast Club</em>, with “Don’t You (Forget About Me)” by Simple Minds, or David Bowie’s timeless tune “Heroes,” which breathed an even richer tenderness into <em>The Perks of Being a Wallflower</em> and its YA outsider story.</p><p>Songs from Troye Sivan, Jack Antonoff’s band Bleachers and HAERTS — and even Whitney’s “I Wanna Dance With Somebody (Who Loves Me),” used to sweet musical-esque effect in the film will enrich the experience for queer teens and adults alike of seeing the groundbreaking gay-led romance <em>Love, Simon</em>.</p><h6><strong>Britney Spears, TBD</strong></h6><p>According to Buzzfeed writers, Britney Spears has a new album coming out in 2018, or very soon, or someday in the next six months to five years. Journo Christian Zamora took to Twitter to gleefully announce that super-songwriter Justin Tranter gave him a very vague “just wait” when asked about a new Brit album for 2018 while on the Golden Globes red carpet in January. Tranter was Spears’ writing partner on her 2016 commercially lackluster but artistically slick standout <em>Glory</em>, and they obviously hit it off because he’s been an integral part of the creative process for B10, as in Britney Spears, album 10. So, watch for this one, whenever it comes out.</p><h6><strong>Brandi Carlile, <em>By the Way, I Forgive You</em></strong></h6><p>Thirteen years into her esteemed career as one of Americana’s most celebrated singer-songwriters, will lesbian crooner Brandi Carlile at last garner a long-overdue mainstream following? She indeed should; as <em>By the Way, I Forgive You</em> is unparalleled by Carlile’s standards, not to mention I haven’t heard an album this front-to-back sublime since Lorde’s summer 2017 release, <em>Melodrama</em>. Aching with raw, lived-in feelings of regret, aging, empathy, love and — for us queers — the outsiderness she sings of on her empowering anthem “The Joke,” Carlile’s latest collection of tender laments (I will never not cry whenever I hear “Most of All”) and explosive alt-rockers perfectly replicate her live sound, thanks to roots producers Dave Cobb and Shooter Jennings. Grammy voters, are you listening?</p><h6><strong>Kacey Musgraves, <em>Golden Hour</em></strong></h6><p>Kacey Musgraves followed her trusty arrow last year, drinking Guinness and talking about reincarnation with Sheryl Crow at her Nashville recording studio, situated above Crow’s horse stable. In December, Musgraves told <em>Entertainment Weekly</em> those “heady” conversations influenced her latest material (wistful Song of the Year-caliber single “Space Cowboy” among them), partly penned by out country songwriter Shane McAnally and due early this year.</p><p>Known for suffusing her queer-affirming liberalism into her folk-country music, the Grammy-winning musician revealed to <em>EW</em> there’s a colorful cast of characters on this new release: “…there’s the lonely girl, the blissful girl, the new wife, the girl that’s missing her mom, the angry girl, the sarcastic girl, the ’60s-sequined Cruella de Vil with the beehive, the shy girl, the life of the party, the winner, the loser.” If we’re lucky, and because she made history in 2014 by being the first country artist to perform at the GLAAD Media Awards, maybe we’ll get another witty ditty a la “Follow Your Arrow” that sticks it to our president’s queer-backward administration.</p><h6><strong>Troye Sivan, TBD</strong></h6><p>It looks like we’ll blessedly be seeing a lot of Troye Sivan’s porcelain-doll face in the coming months — and not just while serving mesmeric, make-a-grown-man-cry poetry on <em>SNL</em>, where the Aussie stunned with a new sonic heartbreaker, “The Good Side,” from his upcoming album. Eyes closed, arms flung out, he swayed his little gay hips during the synth instrumental break. And if you weren’t already won over by Sivan’s queer coming-of-age debut, <em>Blue Neighborhood</em>, released when he was 20, his slip into a pain-shielding meditation on live TV surely captured you. Between “The Good Side” and “My My My,” Sivan’s sophomore release is a transcendent shift in his post-teen sexual awakening and the sometimes-devastating consequences that come with growing up.</p><h6><strong>Robyn, TBD, honey</strong></h6><p>Call your girlfriend, everyone. And hey, while you’re at it, call your boyfriend, your mama, your papa; hell, call your favorite Starbucks barista. Even if it doesn’t seem like the best time to be alive, it is the best time to be alive if you spent 2012 pretending you were Lena Dunham busting a move to Robyn’s “Dancing On My Own” in <em>Girls</em> like I did. The maker of songs that make you caterwaul on the dancefloor is gearing up for her long-awaited comeback album (or albums?) — the follow-up to her brilliant anthological release <em>Body Talk</em> in 2010 — this year. When an impatient fan tweeted, “Who decides your next album release (sic),” the fembot gloriously sassed: “I do. Sometime this year, honey (sic).” We’re so ready — in fact, we’ve <em>been</em> ready.</p><p><em>Chris Azzopardi is the editor of Q Syndicate, the international LGBT wire service. Reach him via his website at www.chris-azzopardi.com and on Twitter (@chrisazzopardi).</em></p><p
class="bawpvc-ajax-counter" data-id="47159"> 0</p><div
class="qsalt-endofcontent" id="qsalt-1414099675"><div
style="margin-right: 9px; " id="qsalt-1873136745"><a
data-bid="1" href="https://qsaltlake.com/linkout/46021" rel="nofollow" target="_blank"><img
width="300" height="250" src='https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/03/15125158/GSBA_QLife_300x250.jpg' alt='' title='GSBA_QLife_300x250'  style=" max-width: 100%; height: auto;"/></a></div></div></div>
<footer
class="entry-footer"><div
class="meta-tags"></div>
</footer><div
class="vce-share-bar"><ul
class="vce-share-items"><li><a
class="fa fa-facebook" href="javascript:void(0);" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2018%2F04%2F30%2Falbum-release-slate%2F&amp;t=7+albums+%28Britney%21+Robyn%21%29+that+will+make+this+year+suck+less"></a></li><li><a
class="fa fa-twitter" href="javascript:void(0);" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2018%2F04%2F30%2Falbum-release-slate%2F&amp;text=7+albums+%28Britney%21+Robyn%21%29+that+will+make+this+year+suck+less"></a></li><li><a
class="fa fa-google-plus" href="javascript:void(0);" data-url="https://plus.google.com/share?url=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2018%2F04%2F30%2Falbum-release-slate%2F"></a></li><li><a
class="fa fa-pinterest" href="javascript:void(0);" data-url="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2018%2F04%2F30%2Falbum-release-slate%2F&amp;media=https%3A%2F%2Fs3-us-west-1.amazonaws.com%2Fqsaltlakecom%2Fwp-content%2Fuploads%2F2018%2F04%2F29111528%2FBrandi.jpg&amp;description=7+albums+%28Britney%21+Robyn%21%29+that+will+make+this+year+suck+less"></a></li><li><a
class="fa fa-linkedin" href="javascript:void(0);" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2018%2F04%2F30%2Falbum-release-slate%2F&amp;title=7+albums+%28Britney%21+Robyn%21%29+that+will+make+this+year+suck+less"></a></li></ul></div>
</article>
<nav
class="prev-next-nav"><div
class="vce-prev-link">
<a
href="https://qsaltlake.com/news/2018/04/30/true-stories/" rel="next"><span
class="img-wrp"><img
width="375" height="195" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/30134344/erikneumann-e1525117459505-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="Erik Neumann" /><span
class="vce-pn-ico"><i
class="fa fa fa-chevron-left"></i></span></span><span
class="vce-prev-next-link">KUER to bring journalists together for True Stories</span></a></div><div
class="vce-next-link">
<a
href="https://qsaltlake.com/news/2018/04/30/ellen-page/" rel="prev"><span
class="img-wrp"><img
width="375" height="195" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/30101648/ellenpage-375x195.jpg" class="attachment-vce-lay-b size-vce-lay-b wp-post-image" alt="Ellen Page" /><span
class="vce-pn-ico"><i
class="fa fa fa-chevron-right"></i></span></span><span
class="vce-prev-next-link">Ellen Page joins &#8216;Tales of the City&#8217; reprisal</span></a></div>
</nav>
</main><div
class="main-box vce-related-box"><h3 class="main-box-title">You may also like</h3><div
class="main-box-inside"><article
class="vce-post vce-lay-d post-44465 post type-post status-publish format-standard has-post-thumbnail hentry category-hear-me-out"><div
class="meta-image">
<a
href="https://qsaltlake.com/news/2017/12/27/hear-best-2017/" title="Hear Me Out: Best of 2017">
<img
width="145" height="100" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/12/05161333/lorde-e1514404388580-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/12/05161333/lorde-e1514404388580-145x100.jpg 145w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/12/05161333/lorde-e1514404388580-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" />							</a></div><header
class="entry-header">
<span
class="meta-category"><a
href="https://qsaltlake.com/news/category/artsandentertainment/hear-me-out/" class="category-198">Hear Me Out</a></span><h2 class="entry-title"><a
href="https://qsaltlake.com/news/2017/12/27/hear-best-2017/" title="Hear Me Out: Best of 2017">Hear Me Out: Best of 2017</a></h2>
</header></article>					<article
class="vce-post vce-lay-d post-42409 post type-post status-publish format-standard hentry category-hear-me-out"><div
class="meta-image">
<a
href="https://qsaltlake.com/news/2017/09/12/11-tunes-help-keep-calm-collected-engaged-current-political-climate/" title="11 tunes to help keep you calm, collected and engaged in our current political climate">
<img
width="145" height="100" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05163057/NoPic-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d" alt="" srcset="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05163057/NoPic-145x100.jpg 145w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05163057/NoPic-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" />							</a></div><header
class="entry-header">
<span
class="meta-category"><a
href="https://qsaltlake.com/news/category/artsandentertainment/hear-me-out/" class="category-198">Hear Me Out</a></span><h2 class="entry-title"><a
href="https://qsaltlake.com/news/2017/09/12/11-tunes-help-keep-calm-collected-engaged-current-political-climate/" title="11 tunes to help keep you calm, collected and engaged in our current political climate">11 tunes to help keep you calm, collected and engaged...</a></h2>
</header></article>					<article
class="vce-post vce-lay-d post-35187 post type-post status-publish format-standard hentry category-hear-me-out"><div
class="meta-image">
<a
href="https://qsaltlake.com/news/2015/05/22/hear-me-out-pride-playlist/" title="11 songs to pimp your Pride playlist">
<img
width="145" height="100" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05163057/NoPic-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d" alt="" srcset="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05163057/NoPic-145x100.jpg 145w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05163057/NoPic-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" />							</a></div><header
class="entry-header">
<span
class="meta-category"><a
href="https://qsaltlake.com/news/category/artsandentertainment/hear-me-out/" class="category-198">Hear Me Out</a></span><h2 class="entry-title"><a
href="https://qsaltlake.com/news/2015/05/22/hear-me-out-pride-playlist/" title="11 songs to pimp your Pride playlist">11 songs to pimp your Pride playlist</a></h2>
</header></article>					<article
class="vce-post vce-lay-d post-31543 post type-post status-publish format-standard has-post-thumbnail hentry category-hear-me-out"><div
class="meta-image">
<a
href="https://qsaltlake.com/news/2013/12/09/hear-holiday-edition-kelly-clarkson-mary-j-blige-erasure-matthew-morrison/" title="Hear Me Out: The Holiday Edition: Kelly Clarkson, Mary J. Blige, Erasure, Matthew Morrison">
<img
width="145" height="100" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2013/12/05171011/Kelly-Clarkson-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2013/12/05171011/Kelly-Clarkson-145x100.jpg 145w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2013/12/05171011/Kelly-Clarkson-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" />							</a></div><header
class="entry-header">
<span
class="meta-category"><a
href="https://qsaltlake.com/news/category/artsandentertainment/hear-me-out/" class="category-198">Hear Me Out</a></span><h2 class="entry-title"><a
href="https://qsaltlake.com/news/2013/12/09/hear-holiday-edition-kelly-clarkson-mary-j-blige-erasure-matthew-morrison/" title="Hear Me Out: The Holiday Edition: Kelly Clarkson, Mary J. Blige, Erasure, Matthew Morrison">Hear Me Out: The Holiday Edition: Kelly Clarkson, Mary...</a></h2>
</header></article>					<article
class="vce-post vce-lay-d post-31540 post type-post status-publish format-standard has-post-thumbnail hentry category-hear-me-out"><div
class="meta-image">
<a
href="https://qsaltlake.com/news/2013/12/04/hear-lady-gaga-arcade-fire/" title="Hear Me Out: Lady Gaga, Arcade Fire">
<img
width="145" height="100" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2013/12/05171012/Lady-Gaga-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2013/12/05171012/Lady-Gaga-145x100.jpg 145w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2013/12/05171012/Lady-Gaga-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" />							</a></div><header
class="entry-header">
<span
class="meta-category"><a
href="https://qsaltlake.com/news/category/artsandentertainment/hear-me-out/" class="category-198">Hear Me Out</a></span><h2 class="entry-title"><a
href="https://qsaltlake.com/news/2013/12/04/hear-lady-gaga-arcade-fire/" title="Hear Me Out: Lady Gaga, Arcade Fire">Hear Me Out: Lady Gaga, Arcade Fire</a></h2>
</header></article>					<article
class="vce-post vce-lay-d post-31236 post type-post status-publish format-standard has-post-thumbnail hentry category-hear-me-out"><div
class="meta-image">
<a
href="https://qsaltlake.com/news/2013/11/11/hear-celine-dion-katy-perry/" title="Hear Me Out: Celine Dion, Katy Perry">
<img
width="145" height="100" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2013/11/05171113/Celine-145x100.jpg" class="attachment-vce-lay-d size-vce-lay-d wp-post-image" alt="" srcset="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2013/11/05171113/Celine-145x100.jpg 145w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2013/11/05171113/Celine-380x260.jpg 380w" sizes="(max-width: 145px) 100vw, 145px" />							</a></div><header
class="entry-header">
<span
class="meta-category"><a
href="https://qsaltlake.com/news/category/artsandentertainment/hear-me-out/" class="category-198">Hear Me Out</a></span><h2 class="entry-title"><a
href="https://qsaltlake.com/news/2013/11/11/hear-celine-dion-katy-perry/" title="Hear Me Out: Celine Dion, Katy Perry">Hear Me Out: Celine Dion, Katy Perry</a></h2>
</header></article></div></div>
<section
class="main-box mbt-border-top author-box"><h3 class="main-box-title">About the author</h3><div
class="main-box-inside"><div
class="data-image"></div><div
class="data-content"><h4 class="author-title">Chris Azzopardi</h4><div
class="data-entry-content"><p>Chris Azzopardi is the editor of Q Syndicate, the international LGBT wire service. He’s also the proud recipient of an “I adore you, daaahhhling!” from Mariah Carey. Reach him via his website at chris-azzopardi.com and on Twitter @chrisazzopardi.</p></div></div></div><div
class="vce-content-outside"><div
class="data-links">
<a
href="https://qsaltlake.com/news/author/chris-azzopardi/" class="vce-author-link vce-button">View all posts</a></div><div
class="vce-author-links"></div></div></section><div
id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a
rel="nofollow" id="cancel-comment-reply-link" href="/news/2018/04/30/album-release-slate/#respond" style="display:none;">X</a></small></h3><p
class="must-log-in">You must be <a
href="https://qsaltlake.com/wp-login.php?redirect_to=https%3A%2F%2Fqsaltlake.com%2Fnews%2F2018%2F04%2F30%2Falbum-release-slate%2F">logged in</a> to post a comment.</p></div></div><aside
id="sidebar" class="sidebar right"><div
id="mks_ads_widget-7" class="widget mks_ads_widget"><h4 class="widget-title">Online Edition</h4><ul
class="mks_adswidget_ul custom"><li
data-showind="0">
<a
href="https://qsaltlake.com/current-q/" target="_blank" >
<img
src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/17190255/qsl1805e_257x321.jpg" alt="qsl1805e_257x321.jpg" style="width:257px; height:321px;" width="257"  height="321"/>
</a></li></ul></div><div
id="mks_ads_widget-1" class="widget mks_ads_widget"><ul
class="mks_adswidget_ul large"><li
data-showind="0"><div
style="width:300px; height:250px;"></div></li></ul></div><div
id="vce_posts_widget-2" class="widget vce_posts_widget"><h4 class="widget-title">Featured Posts</h4><ul
class="vce-post-slider" data-autoplay=""><li>
<a
href="https://qsaltlake.com/news/2018/04/30/true-stories/" class="featured_image_sidebar" title="KUER to bring journalists together for True Stories"><span
class="vce-post-img"><img
width="380" height="260" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/30134344/erikneumann-e1525117459505-380x260.jpg" class="attachment-vce-fa-grid size-vce-fa-grid wp-post-image" alt="Erik Neumann" srcset="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/30134344/erikneumann-e1525117459505-380x260.jpg 380w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/30134344/erikneumann-e1525117459505-145x100.jpg 145w" sizes="(max-width: 380px) 100vw, 380px" /></span></a><div
class="vce-posts-wrap">
<a
href="https://qsaltlake.com/news/2018/04/30/true-stories/" title="KUER to bring journalists together for True Stories" class="vce-post-link">KUER to bring journalists together for True Stories</a><div
class="entry-meta"><div
class="meta-item rtime">2 min read</div></div></div></li><li>
<a
href="https://qsaltlake.com/news/2018/04/27/national-small-business-week/" class="featured_image_sidebar" title="National Small Business Week starts this weekend"><span
class="vce-post-img"><img
width="380" height="260" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/27131845/smallbusiness-e1524856765200-380x260.jpeg" class="attachment-vce-fa-grid size-vce-fa-grid wp-post-image" alt="National Small Business Week" srcset="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/27131845/smallbusiness-e1524856765200-380x260.jpeg 380w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/27131845/smallbusiness-e1524856765200-145x100.jpeg 145w" sizes="(max-width: 380px) 100vw, 380px" /></span></a><div
class="vce-posts-wrap">
<a
href="https://qsaltlake.com/news/2018/04/27/national-small-business-week/" title="National Small Business Week starts this weekend" class="vce-post-link">National Small Business Week starts this weekend</a><div
class="entry-meta"><div
class="meta-item rtime">5 min read</div></div></div></li><li>
<a
href="https://qsaltlake.com/news/2018/04/27/fluff-party/" class="featured_image_sidebar" title="Fluff Party: a furry dance at Club Try-Angles"><span
class="vce-post-img"><img
width="380" height="260" src="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/27122937/furries-e1524853815858-380x260.jpg" class="attachment-vce-fa-grid size-vce-fa-grid wp-post-image" alt="Fluff Party" srcset="https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/27122937/furries-e1524853815858-380x260.jpg 380w, https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2018/04/27122937/furries-e1524853815858-145x100.jpg 145w" sizes="(max-width: 380px) 100vw, 380px" /></span></a><div
class="vce-posts-wrap">
<a
href="https://qsaltlake.com/news/2018/04/27/fluff-party/" title="Fluff Party: a furry dance at Club Try-Angles" class="vce-post-link">Fluff Party: a furry dance at Club Try-Angles</a><div
class="entry-meta"><div
class="meta-item rtime">4 min read</div></div></div></li></ul></div><div
id="mks_ads_widget-4" class="widget mks_ads_widget"><h4 class="widget-title">Support our sponsors</h4><ul
class="mks_adswidget_ul small"><li
data-showind="0"><div
style="width:125px; height:125px;">
<a
data-bid="1" href="https://qsaltlake.com/linkout/42242" rel="nofollow" target="_blank"><img
width="125" height="125" src='https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05162534/FriarTuck_125x125.jpg' alt='' title='FriarTuck_125x125'  style=" max-width: 100%; height: auto;"/></a></div></li><li
data-showind="0"><div
style="width:125px; height:125px;"><div
style="margin-left: 1px; " id="qsalt-156677871"><a
data-bid="1" href="https://qsaltlake.com/linkout/42243" rel="nofollow" target="_blank"><img
width="125" height="125" src='https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05162535/LGBTQTherapist_web125-1.gif' alt='' title='LGBTQTherapist_web125'  style=" max-width: 100%; height: auto;"/></a></div></div></li><li
data-showind="0"><div
style="width:125px; height:125px;">
<a
data-bid="1" href="https://qsaltlake.com/linkout/42249" rel="nofollow" target="_blank"><img
width="125" height="125" src='https://s3-us-west-1.amazonaws.com/qsaltlakecom/wp-content/uploads/2017/08/05163025/ThomasTravel125.jpg' alt='' title='ThomasTravel125'  style=" max-width: 100%; height: auto;"/></a></div></li><li
data-showind="0"><div
style="width:125px; height:125px;"></div></li><li
data-showind="0"><div
style="width:125px; height:125px;"></div></li><li
data-showind="0"><div
style="width:125px; height:125px;"></div></li><li
data-showind="0"><div
style="width:125px; height:125px;"></div></li><li
data-showind="0"><div
style="width:125px; height:125px;"></div></li></ul></div><div
id="mks_ads_widget-6" class="widget mks_ads_widget"><h4 class="widget-title">Advertisement</h4><ul
class="mks_adswidget_ul custom"><li
data-showind="0"><div
style="width:300px; height:600px;"></div></li></ul></div><div
class="vce-sticky"><div
id="mks_ads_widget-2" class="widget mks_ads_widget"><h4 class="widget-title">Advertisement</h4><ul
class="mks_adswidget_ul small"><li
data-showind="0"><div
style="width:125px; height:125px;"></div></li><li
data-showind="0"><div
style="width:125px; height:125px;"></div></li><li
data-showind="0"><div
style="width:125px; height:125px;"></div></li><li
data-showind="0"><div
style="width:125px; height:125px;"></div></li></ul></div></div>	</aside></div><footer
id="footer" class="site-footer"><div
class="container"><div
class="container-fix"><div
class="bit-3"></div><div
class="bit-3"></div><div
class="bit-3"><div
id="mks_social_widget-2" class="widget mks_social_widget"><h4 class="widget-title">Join Us</h4><ul
class="mks_social_widget_ul"><li><a
href="#" title="Instagram" class="instagram_ico soc_rounded" target="_blank" style="width: 47px; height: 47px; font-size: 16px;"><span>instagram</span></a></li><li><a
href="#" title="Twitter" class="twitter_ico soc_rounded" target="_blank" style="width: 47px; height: 47px; font-size: 16px;"><span>twitter</span></a></li><li><a
href="#" title="Facebook" class="facebook_ico soc_rounded" target="_blank" style="width: 47px; height: 47px; font-size: 16px;"><span>facebook</span></a></li><li><a
href="#" title="" class="googleplus_ico soc_rounded" target="_blank" style="width: 47px; height: 47px; font-size: 16px;"><span>googleplus</span></a></li><li><a
href="#" title="Pinterest" class="pinterest_ico soc_rounded" target="_blank" style="width: 47px; height: 47px; font-size: 16px;"><span>pinterest</span></a></li><li><a
href="#" title="RSS" class="rss_ico soc_rounded" target="_blank" style="width: 47px; height: 47px; font-size: 16px;"><span>rss</span></a></li></ul></div></div></div></div><div
class="container-full site-info"><div
class="container"><div
class="vce-wrap-left"><p>Copyright &copy; 2014. Created by <a
href="http://mekshq.com" target="_blank">Meks</a>. Powered by <a
href="http://www.wordpress.org" target="_blank">WordPress</a>.</p></div><div
class="vce-wrap-right"><ul
id="vce_footer_menu" class="bottom-nav-menu"><li
id="menu-item-19427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19427"><a
href="https://qsaltlake.com/about/">About Us</a></li><li
id="menu-item-19428" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19428"><a
href="https://qsaltlake.com/about/advertising/">Advertising</a></li><li
id="menu-item-19429" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19429"><a
href="https://qsaltlake.com/about/contact-us/">Contact Us</a></li><li
id="menu-item-19426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19426"><a
href="https://qsaltlake.com/classifieds/">Classifieds</a></li><li
id="menu-item-19430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19430"><a
href="https://qsaltlake.com/about/privacy/">Privacy</a></li></ul></div></div></div></footer></div></div><a
href="javascript:void(0)" id="back-top"><i
class="fa fa-angle-up"></i></a> <script>/*<![CDATA[*/var advanced_ads_ga_UID='';advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();/*]]>*/</script> <script type="text/javascript">analytics.track("Viewed Post",{"title":"7 albums (Britney! Robyn!) that will make this year suck less","category":"Hear Me Out","noninteraction":true},{"library":"analytics-wordpress"});</script> <script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='96178a0064b7670090e48d0056d1bf00a77d00004cea7500a2ac9400d4c7cd00';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script><script type='text/javascript'>var wpcf7={"apiSettings":{"root":"https:\/\/qsaltlake.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};</script> <script type='text/javascript' src='https://qsaltlake.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.1'></script> <script type='text/javascript' src='https://qsaltlake.com/wp-content/uploads/134/335/public/assets/js/669.js?ver=1.6'></script> <script type='text/javascript'>var advanced_ads_sticky_settings={"check_position_fixed":""};</script> <script type='text/javascript' src='https://qsaltlake.com/wp-content/uploads/134/85/public/assets/js/504.js?ver=1.7.4'></script> <script type='text/javascript'>var vce_js_settings={"sticky_header":"1","sticky_header_offset":"700","sticky_header_logo":"https:\/\/qsaltlake.com\/wp-content\/uploads\/2017\/08\/qsl_logo_small.png","logo":"https:\/\/s3-us-west-1.amazonaws.com\/qsaltlakecom\/wp-content\/uploads\/2017\/08\/05163103\/QSaltLakeMasthead.png","logo_retina":"","logo_mobile":"","logo_mobile_retina":"","rtl_mode":"0","ajax_url":"https:\/\/qsaltlake.com\/wp-admin\/admin-ajax.php","ajax_mega_menu":"1","mega_menu_slider":"","mega_menu_subcats":"","lay_fa_grid_center":"","full_slider_autoplay":"","grid_slider_autoplay":"","fa_big_opacity":{"1":"0.5","2":"0.7"},"top_bar_mobile":"1","top_bar_mobile_group":"","top_bar_more_link":"More"};</script> <script type='text/javascript' src='https://qsaltlake.com/wp-content/themes/voice/js/min.js?ver=2.5'></script> <script type="text/javascript">var advads_tracking_ads={};var advads_tracking_urls=[];var advads_gatracking_uids=[];var advads_tracking_methods=[];var advads_tracking_parallel=[];var advads_tracking_linkbases=[];var advads_gatracking_allads=[];</script><script>/*<![CDATA[*/jQuery(document).ready(function($){$('.bawpvc-ajax-counter').each(function(i){var $id=$(this).data('id');var t=this;var n=1;$.get('https://qsaltlake.com/wp-admin/admin-ajax.php?action=bawpvc-ajax-counter&p='+$id+'&n='+n,function(html){$(t).html(html);})});});/*]]>*/</script> <script type="text/javascript" src="https://qsaltlake.com/wp-content/cache/minify/67e07.default.include-footer.d77e83.js"></script> </body></html>